HDU5501The Highest Mark 背包+贪心确定排序标准

http://acm.hdu.edu.cn/showproblem.php?pid=5501

考虑t1,t2

t1先做的话,那么消耗c1*b1+b2*(C1+c2)

t2先做的话,那么消耗c2*b2+b1*(c1+c2)

可以看出c1b2和b1c2不同,其他的都相同,所以排序标准确定了。

Problem Description

The SDOI in 2045 is far from what it was been 30 years ago. Each competition has t minutes and n problems.

The ith problem with the original mark of Ai(Ai≤106) ,and it decreases Bi by each minute. It is guaranteed that it does not go to minus when the competition ends. For example someone solves the ith problem after x minutes of the competition beginning. He/She will get Ai−Bi∗x marks.

If someone solves a problem on x minute. He/She will begin to solve the next problem on x+1 minute.

dxy who attend this competition with excellent strength, can measure the time of solving each problem exactly.He will spend Ci(Ci≤t) minutes to solve the ith problem. It is because he is so godlike that he can solve every problem of this competition. But to the limitation of time, it's probable he cannot solve every problem in this competition. He wanted to arrange the order of solving problems to get the highest mark in this competition.

 

 

Input

There is an positive integer T(T≤10) in the first line for the number of testcases.(the number of testcases with n>200 is no more than 5 )

For each testcase, there are two integers in the first line n(1≤n≤1000) and t(1≤t≤3000) for the number of problems and the time limitation of this competition.

There are n lines followed and three positive integers each line Ai,Bi,Ci . For the original mark,the mark decreasing per minute and the time dxy of solving this problem will spend.


Hint:
First to solve problem 2 and then solve problem 1 he will get 88 marks. Higher than any other order.

 

 

Output

For each testcase output a line for an integer, for the highest mark dxy will get in this competition.

 

 

Sample Input

 

1 4 10 110 5 9 30 2 1 80 4 8 50 3 2

 

 

Sample Output

 

88

 

 

Source

BestCoder Round #59 (div.1)

 

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll dp[350000];
struct node{
    ll A;
    ll B;
    ll C;
}arr[100000];
bool cmp(node t1,node t2)
{
    return t2.B*t1.C<t1.B*t2.C;
}
int main()
{

    ll T;
    scanf("%lld",&T);
    while(T--)
    {
        ll n,t;
        memset(dp,0,sizeof(dp));
        scanf("%lld%lld",&n,&t);
        for(ll i=1; i<=n; i++)
        {
            scanf("%lld%lld%lld",&arr[i].A,&arr[i].B,&arr[i].C );

        }
        sort(arr+1,arr+n+1,cmp);
        for(ll i=1; i<=n; i++)
        {
            for(ll j=t; j>=arr[i].C; j--)
            {
                dp[j]=max(dp[j],dp[j-arr[i].C]+arr[i].A-arr[i].B*j);
//dp[j]表示j时刻
            }
        }
        ll ans = 0;
        for(ll i = 0; i <=t; i++)
        {
            ans = max(ans, dp[i]);
        }
        printf("%lld\n", ans);
    }
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值