HDU 4810 Wall Painting 组合数+位运算

本文探讨了一位热爱绘画的女士如何通过混合不同颜色的颜料来创作她的作品《伟大的趣味墙》。每天,她都会从众多颜料袋中选择特定数量的颜料,通过异或运算创造出独特的色彩。丈夫试图计算所有可能的色彩组合总和,这涉及到组合数学和二进制位操作的知识。
摘要由CSDN通过智能技术生成

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B. 
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with different plans. 

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6. 
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him? 
You should tell Mr.Fang the answer from the first day to the n-th day.

Input

There are several test cases, please process till EOF. 
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output

For each test case, output N integers in a line representing the answers(mod 10 6 +3) from the first day to the n-th day.

Sample Input

4
1 2 10 1

Sample Output

14 36 30 8
1.首先打表出组合数
2.从二进制角度看问题
0001
0010
1010
0001
是题中所给数据
我们统计每一位上1的个数o,那么n-o就是0的了
从o中选出奇数个1,因为偶数个1异或还是0.
选出1后和0配对,也就是组合数相乘。
注意每次还要乘上对应位上的权值。
#include <bits/stdc++.h>
#define N 1050
#define mod 1000003
typedef long long LL;
using namespace std;
LL c[N][N];
void init()
{
    for(int i=0; i<N; i++)
    {
        c[i][0]=c[i][i]=1;
    }
    for(int i=2; i<N; i++)
    {
        for(int j=1; j<i; j++)
        {
            c[i][j]=(c[i-1][j]+c[i-1][j-1])%mod;
        }
    }
}//打表计算组合数
LL a[32];
int main()
{
    // cout<<(1<<2)<<" "<<(1>>2);
    init();
    LL t;
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++)
        {
            int j=0;
            scanf("%lld",&t);
            while(t)
            {
                if(t&1)
                {
                    a[j]++;
                }
                j++;
                t>>=1;
            }
        }
        for(int k=1; k<=n; k++)
        {
            LL sum=0;
            int t=1;
            for(int i=0; i<32; i++)
            {
                LL ans=0;
                for(int j=1; j<=k; j+=2)
                {
                    ans=(ans+c[a[i]][j]*c[n-a[i]][k-j]%mod)%mod;
                    ans%=mod;
                }
                sum=(t*ans%mod+sum%mod)%mod;//对于每一位来说
                t*=2;
            }
            if(k==1)
            {
                printf("%lld",sum);
            }
            else
            {
                printf(" %lld",sum);
            }
        }
        printf("\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值