POJ 2955 Brackets 区间dp

http://poj.org/problem?id=2955

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

<span style="color:#000000">((()))
()()()
([]])
)[)(
([][][)
end</span>

Sample Output

<span style="color:#000000">6
6
4
0
6</span>

枚举思想,中间枚举一层断点

#include <bits/stdc++.h>
using namespace std;
#define LL long long
#define maxn 600
char str[maxn];
int num[maxn][maxn];
int main()
{
    while(scanf("%s",&str)&&strcmp("end",str)){
        memset(num,0,sizeof(num));
        int n=strlen(str);
        for(int len=2;len<=n;len++){
            for(int i=0;i<n;i++){
                int j=i+len-1;
                if(j>n)break;
                if((str[i]=='('&&str[j]==')')||(str[i]=='['&&str[j]==']')){
                    num[i][j]=num[i+1][j-1]+2;
                }else{
                    num[i][j]=num[i+1][j-1];
                }
                for(int k=i;k<j;k++){
                    //枚举断点
                    num[i][j]=max(num[i][j],num[i][k]+num[k+1][j]);
                }
            }
        }
        cout<<num[0][n-1]<<endl;
    }


}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值