POJ - 2785 4 Values whose Sum is 0(二分)

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

开四个数组 预处理出前两个 与 后两个数组 各项的和分别为e f

然后在e 里找f

#include<iostream>
#include<algorithm>
using namespace std;
#define N 4066
int a[N],b[N],c[N],d[N],e[N*N],f[N*N];
int main(){
    int t,i,j,q=0;
    cin>>t;
    for(i=0;i<t;i++)    
        cin>>a[i]>>b[i]>>c[i]>>d[i];//a[i]是第i行
    for(i=0;i<t;i++)
        for(j=0;j<t;j++)
            e[i*t+j]=a[i]+b[j];
    for(i=0;i<t;i++)
        for(j=0;j<t;j++)
            f[i*t+j]=c[i]+d[j];
    sort(e,e+t*t);
    sort(f,f+t*t);  
    for(i=0;i<t*t;i++)
            q+=upper_bound(e,e+t*t,-f[i])-lower_bound(e,e+t*t,-f[i]);
    cout<<q;    

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值