Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2 100 200
Sample Output
-74.4291 -178.8534
输入是y
#include<iostream>
#include<stdio.h>
#include<map>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
#include<string>
#include<cstring>
using namespace std;
#define ll long long
double y;
double ans(double x)
{
return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
double is(double x)
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
int main()
{
//cout<<ans(-74.4291);
int t;
cin>>t;
while(t--)
{
scanf("%lf",&y);
double l=0,r=100;
double mid;
while(r-l>0.00000001)
{
mid=(l+r)/2;
if(is(mid)>0){
r=mid;
}
else if(is(mid)<0){
l=mid;
}
else{
break;
}
}
printf("%.4lf\n",ans(mid));
}
}