二分+数组合并思想

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

这里先把a,b数组合并,再排序,与c数组进行二分

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define ll long long
ll a[510];
ll b[510];
ll c[510];
ll d[250010];
int k;
int main()
{
    int n,m,l,s;
    int o=0;
    while(scanf("%d%d%d",&l,&n,&m)!=EOF)
    {
        printf("Case %d:\n",++o);
        k=0;
        for(int i=1;i<=l;i++){
            scanf("%lld",&a[i]);
        }
        for(int i=1;i<=n;i++){
            scanf("%lld",&b[i]);
        }
        for(int i=1;i<=m;i++){
            scanf("%lld",&c[i]);
        }
        for(int i=1;i<=l;i++){
            for(int j=1;j<=n;j++){
                d[++k]=a[i]+b[j];
            }
        }
        sort(d+1,d+k+1);
        scanf("%d",&s);
        while(s--)
        {
            bool flag;
            long long x;
            scanf("%lld",&x);
            for(int i=1;i<=m;i++){
                int l=1,r=k,mid;
                flag=false;
                while(r>=l)
                {
                    mid=(l+r)>>1;
                    if(d[mid]+c[i]==x){
                        flag=true;
                        break;
                    }
                    else if(d[mid]+c[i]>x){
                        r=mid-1;
                    }
                    else{
                        l=mid+1;
                    }
                }
                if(flag)break;
            }
            if(flag)printf("YES\n");
            else{
                printf("NO\n");
            }
        }

    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值