AtCoder Regular Contest 067--C - Factors of Factorial--数学思想

C - Factors of Factorial
Time Limit: 2 sec / Memory Limit: 256 MB
Score :  points
Problem Statement You are given an integer . Find the number of the positive divisors of , modulo .
Constraints
Input The input is given from Standard Input in the following format:
 
Output Print the number of the positive divisors of , modulo .
Sample Input 1

Sample Output 1

There are four divisors of  : , ,  and . Thus, the output should be .
Sample Input 2

Sample Output 2
30 
Sample Input 3
1000 
Sample Output 3
972926972 
把N的阶乘写成质因子相乘的形式

思路:

N!=2^A+3^B+5^C+.....

然后因子个数就是(A+1)*(B+1)*...  2可以选0~A。

#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
#define ll long long
const int mod=1e9+7;
const int maxn=1e5+10;
int f[maxn];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=2;i<=n;i++)
    {
        int a=i;//4//---
        for(int j=2;j<=a;j++)
        {
            while(!(a%j))
            {
                f[j]++;
                a/=j;
            }
        }
        if(a!=1)
            f[a]++;
    }
    ll ans=1;
    for(int i=1;i<=n;i++)
    {
        if(f[i])ans*=(1+f[i])%mod;
        ans%=mod;
    }
    printf("%d\n",ans%mod);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值