POJ2138--Travel Games--最长路||BFS

Travel Games

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4471 Accepted: 1612

Description

The cows are taking a trip to the lakes in Minnesota. Like everyone else, they are bored and are playing "travel games" to pass the time away. 

In this travel game, the first cow thinks of a three letter word from the Sacred Travel Game Dictionary (STGD). The next cow in line must add a letter to the word (at the beginning, between two letters, or at the end) to make another word in the STGD. The cows are curious as to just how big the final word can be. 

Given a dictionary of D (1 <= D <= 1000) words and a starting word, find any of the longest possible words that can be formed playing this travel game. 

Input

* Line 1: The integer D followed by a space followed by a legal three letter word. 

* Line 2 through D+1: Each line contains a legal word no longer than 80 characters, consisting only of lowercase letters, from the STGD. 

Output

A single line with the longest word that can be formed by extending the input seed. 
The input ensure the correct result will be unique.

Sample Input

9 cal
cal
calf
calfs
call
calls
choral
chorale
coal
coral

Sample Output

chorale

Hint

[From the sequence: cal, coal, coral, choral, chorale]

Source

USACO 2003 February Orange

 借鉴的别人最长路写法,太神奇了。判断子序列后加边I->J,然后再求最长路即可。

//By SiriusRen
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 3005
int n,first[N],next[N*N],v[N*N],tot=1,t,head,tail=1,q[N*N];
struct Node
{
    char a[1088];
    int len;
} str[1005];
void add(int x,int y)
{
    v[tot]=y,next[tot]=first[x],first[x]=tot++;
}
int main()
{
    scanf("%d",&n);
    for(int i=0; i<=n; i++)
        scanf("%s",str[i].a),str[i].len=strlen(str[i].a);
    for(int i=0; i<=n; i++)
        for(int j=0; j<=n; j++)
            if(str[i].len+1==str[j].len)
            {
                int tempa=0,tempb=str[j].len-1;
                while(str[i].a[tempa]==str[j].a[tempa])
                    tempa++;
                while(str[i].a[tempb-1]==str[j].a[tempb])
                    tempb--;
                if(tempa>=tempb)
                    add(i,j);//判断子序列
            }
    while(head<tail)
    {
        t=q[head++];//------------------
        for(int i=first[t]; i; i=next[i])
            q[tail++]=v[i];//---//
    }
    printf("%s",str[t].a);//---//
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值