AtCoder - 2660 --Cat Snuke and a Voyage--最短路思维

Problem Statement

 

In Takahashi Kingdom, there is an archipelago of N islands, called Takahashi Islands. For convenience, we will call them Island 1, Island 2, ..., Island N.

There are M kinds of regular boat services between these islands. Each service connects two islands. The i-th service connects Island ai and Island bi.

Cat Snuke is on Island 1 now, and wants to go to Island N. However, it turned out that there is no boat service from Island 1 to Island N, so he wants to know whether it is possible to go to Island N by using two boat services.

Help him.

Constraints

 

  • 3≤N≤200 000
  • 1≤M≤200 000
  • 1≤ai<biN
  • (ai,bi)≠(1,N)
  • If ij, (ai,bi)≠(aj,bj).

Input

 

Input is given from Standard Input in the following format:

N M
a1 b1
a2 b2
:
aM bM

Output

 

If it is possible to go to Island N by using two boat services, print POSSIBLE; otherwise, print IMPOSSIBLE.

Sample Input 1

 

3 2
1 2
2 3

Sample Output 1

 

POSSIBLE

Sample Input 2

 

4 3
1 2
2 3
3 4

Sample Output 2

 

IMPOSSIBLE

You have to use three boat services to get to Island 4.

Sample Input 3

 

100000 1
1 99999

Sample Output 3

 

IMPOSSIBLE

Sample Input 4

 

5 5
1 3
4 5
2 3
2 4
1 4

Sample Output 4

 

POSSIBLE

You can get to Island 5 by using two boat services: Island 1 -> Island 4 -> Island 5.

判断1-n之间的距离是否为2

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define MAX 0X3f3f3f3f
#define maxn 200000+10
int vis[200006];
map<int,int>mmp;
int main()
{
    int n,m;
    cin>>n>>m;
    //1-n是否路径只有2
    string s2="IMPOSSIBLE";
    for(int i=1;i<=m;i++)
    {
        int a,b;
        cin>>a>>b;
        if(a==1)
        {
            if(vis[b])
            {
                s2="POSSIBLE";
            }
            vis[b]=1;
        }
        if(b==n)
        {
            if(vis[a])
            {
                s2="POSSIBLE";
            }
            vis[a]=1;
        }
    }
    cout<<s2<<endl;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值