东华OJ 基础题106 大整数相加——难度中

问题描述 :

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

输入说明 :

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

输出说明 :

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

输入范例 :

2
1 2
112233445566778899 998877665544332211

输出范例 :

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

完整C++代码

#include <bits/stdc++.h>

using namespace std;

int main()
{
	int n;
	cin >> n;
	for (int j = 1; j <= n; j++) {
		string s, ss;
		cin >> s >> ss;
		int a[1000] = {0}, b[1000] = {0}, c[1000] = {0};
		// 将数倒过来,分别进行同位相加
		for (int i = 0; i < s.size(); i++) {
			a[s.size() - i - 1] = s[i] - '0';
		}
		for (int i = 0; i < ss.size(); i++) {
			b[ss.size() - i - 1] = ss[i] - '0';
		}
		int c_len = max(s.size(), ss.size());
		// 进位
		int step = 0;
		for (int i = 0; i < c_len; i++) {
			c[i] = (a[i] + b[i] + step) % 10;
			step = (a[i] + b[i] + step) / 10;
		}
		// 进位数不为0,就要再加一位
		if (step != 0) {
			c[c_len] = step;
			c_len++;
		}
		cout << "Case " << j << ":" << endl;
		cout << s << " + " << ss << " = ";
		for (int i = c_len - 1; i >= 0; i--) {
			cout << c[i];
		}
		cout << endl;
		cout << endl;
	}
	return 0;
}

😋欢迎大伙私信或者评论区交流讨论😋

  • 8
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值