hd 1076 An Easy Task

 

An Easy Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14040    Accepted Submission(s): 8971


Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.
 


 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).
 


 

Output
For each test case, you should output the Nth leap year from year Y.
 


 

Sample Input
  
  
3 2005 25 1855 12 2004 10000
 


 

Sample Output
  
  
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
 


 

Author
Ignatius.L
 


 

Recommend
We have carefully selected several similar problems for you:   1097  1020  1032  1170  1064 
 


 

#include<stdio.h>
#define leapyear(y) y%400==0||(y%4==0&&y%100!=0)
int main()
{
    int t,y,n,p,i;
    while(scanf("%d",&t)!=EOF)
    {
      while(t--)                         
    {
        p=0;
        scanf("%d%d",&y,&n);
        for(i=y;p<n;i++)
        if(leapyear(i))  p++;
        printf("%d\n",i-1);
                                          }
                                          }
return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值