[1001]A+B Format (using java)

[1001]A+B Format (20 分)
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10
​6
​​ ≤a,b≤10
​6
​​ . The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

1.因为不知道System.out.printf()有可以用逗号格式化1000以上数字的功能,便用字符串处理来自己写了一个,很是麻烦。

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        String string = scanner.nextLine();
        scanner.close();
        StringBuilder input = new StringBuilder(string);
        int spaceAt = input.indexOf(" ");
        String a = input.substring(0, spaceAt);
        String b = input.substring(spaceAt + 1, input.length());

        Integer aInteger = Integer.parseInt(a);
        Integer bInteger = Integer.parseInt(b);
        Integer cInteger = aInteger + bInteger;

        boolean nag = false;
        if (cInteger < 0) {
            nag = true;
        }
        StringBuilder cString = new StringBuilder(cInteger.toString());
        int num = 0;
        int len = cString.length();
        if (cString.length() > 3) {

            if (!nag) {
                for (int i = 0 ; i <cString.length(); i++) {
                    num++;
                    if (num % 3 == 0 && num < len) {
                        String right = "," + cString.substring(cString.length()-i-1);
                        cString.delete(cString.length()-i-1, cString.length());
                        cString.append(right);
                        i++;
                    }

                }
            } else {
                for (int i = 0; i<cString.length(); i++) {
                    num++;
                    if (num % 3 == 0 && num < len - 1) {
                        String right = "," + cString.substring(cString.length()-i-1);
                        cString.delete(cString.length()-i-1, cString.length());
                        cString.append(right);
                        i++;
                    }

                }
            }
        }

        System.out.println(cString);
    }
}

2.后来看别人写的才知道用格式化输出,几行代码就搞定了:

        public static void main(String[] args){
            Scanner sc=new Scanner(System.in);
            int a = sc.nextInt();
            int b = sc.nextInt();
            System.out.printf("%,d", a+b);
        }

3.于是找到了System.out.printf()的格式化的形式:

这里写图片描述

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值