hdu 1241 Oil Deposits (dfs经典入门)

本题链接:点击打开链接

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30421    Accepted Submission(s): 17620


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1242  1240  1181  1253  1072 
 
本题题意: 输入n,m代表地图的长和宽,其中*表示不是油田,@表示油田,而在@四周八个相邻点若是也存在@,则这几个@同属于一个油田,现在就是要在地图上寻找油田的个数。

解题思路:先将每个@都看成是一个单独的油田,再判断下这个@是否与上一个@同属于一个油田,是就减一

代码1:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char mp[105][105];
int dir[8][2]= {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,1},{1,-1},{1,0}}; //游历方向
int n,m,num;                    //num 记录油田数目
int ok(int x,int y)            //判断是否越界
{

    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
void dfs(int x,int y,int t)
{
    int i,nx,ny;
    num=t+1;                         //先将这个找到的这个‘@’,视为一个新油田
    for(i=0; i<8; i++)
    {
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        if(mp[nx][ny]=='@'&&ok(nx,ny))
        {
            mp[nx][ny]='*';
            dfs(nx,ny,num-1);       //num-1是因为这个‘@’与上一个油田属于同一个油田,油田数目也就没必要加一了(前面num=t+1)
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        int i,j;
        num=0;
        for(i=0; i<n; i++)
            scanf("%s",mp[i]);
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
            {
                if(mp[i][j]=='@')
                {
                    dfs(i,j,num);
                }
            }
        printf("%d\n",num);
    }
    return 0;
}

代码2:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char mp[101][101];
int dir[8][2]= {{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
int c,n,m;
void dfs(int x,int y)
{
    int nx,ny;
    if(mp[x][y]!='@'||x<0||y<0||x>=n||y>=m) return ;   //不是油田就return,寻找下一个油田
    for(int i=0; i<8; i++)
    {
        mp[x][y]='*';
        nx=x+dir[i][0];
        ny=y+dir[i][1];
        dfs(nx,ny);
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        c=0;
        memset(mp,'*',sizeof(mp));
        for(int i=0; i<n; i++)
            scanf("%s",mp[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
            {
                if(mp[i][j]=='@')
                {
                    dfs(i,j);
                    c++;
                }
            }
        printf("%d\n",c);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值