PAT Basic Level Practise 1020坑点

8 篇文章 0 订阅
7 篇文章 0 订阅

月饼 (25)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。
注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。
输入格式:
每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:
对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:
3 20
18 15 10
75 72 45
输出样例:
94.50

下面的代码,第二个测试点过不去,被扣了两分

/*
2018/1/28
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct moon{
    int kc;
    int sj;
    double dj;
};

int compare(moon a,moon b){
    return a.dj>b.dj;
}

struct moon ary[1005];

int main(){
    //freopen("1020input.txt","r",stdin);
    int n;
    cin>>n;
    int all;
    cin>>all;
    for(int i=0;i<n;i++){
        cin>>ary[i].kc;
    }
    for(int i=0;i<n;i++){
        cin>>ary[i].sj;
        ary[i].dj=(1.0*ary[i].sj)/ary[i].kc;
    }
    sort(ary,ary+n,compare);
    double sy=0;
    int j=0;
    while (all>0&&j<n) {
        if(ary[j].kc<all){
            all-=ary[j].kc;
            sy+=ary[j].sj;
        }else{
            sy+=all*ary[j].dj;
            all=0;
        }
        j++;
    }
    printf("%.2lf\n", sy);
    return 0;
}

后来看了别人的代码,库存和总售价的int改成了double,计算单价那里也不*1.0转double了,居然过了,下面是AC的代码

/*
2018/1/28
*/
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct moon{
    double kc;
    double sj;
    double dj;
};

int compare(moon a,moon b){
    return a.dj>b.dj;
}

struct moon ary[1005];

int main(){
    //freopen("1020input.txt","r",stdin);
    int n;
    cin>>n;
    int all;
    cin>>all;
    for(int i=0;i<n;i++){
        cin>>ary[i].kc;
    }
    for(int i=0;i<n;i++){
        cin>>ary[i].sj;
        ary[i].dj=ary[i].sj/ary[i].kc;
    }
    sort(ary,ary+n,compare);
    double sy=0;
    int j=0;
    while (all>0&&j<n) {
        if(ary[j].kc<all){
            all-=ary[j].kc;
            sy+=ary[j].sj;
        }else{
            sy+=all*ary[j].dj;
            all=0;
        }
        j++;
    }
    printf("%.2lf\n", sy);
    return 0;
}

无语凝噎,好想找陈越姥姥要测评数据。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值