poj 3348 Cows

题目衔接:http://poj.org/problem?id=3348

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12485 Accepted: 5418

Description

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees. 

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

 题目大意:给你n个点,问你这n个点中的其中某些点所能组成的最大的多边形的面积

思路:凸包模板题,扫一下发现是哪些点作为顶点,然后使用三角形叉积求面即可

代码: 

/*
题目大意:现在给你n个点,让你使用这些点构成一个面积尽可能大的多边形,注意这些点不是会被全部使用


思路:凸包,直接求面积即可
*/
#include<set>
#include<map>
#include<ctime>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f
#define bug  printf("bug\n")
const int maxn=1e6+10;
const double pi=acos(-1.0);
const double esp=1e-6;
const int N=2e2+10;
struct point
{
    int x,y;
};
struct line
{
    point st,ed;
    double k,b;
};
int sign(double x)
{
    if(fabs(x)<esp)
        return 0;
    return x>0?1:-1;
}
double getk(line l)
{
    if(l.st.x==l.ed.x)///斜率不存在
        return inf;
    return (l.ed.y-l.st.y)/(l.ed.x-l.st.x);
}
double getb(line l)
{
    return l.ed.y-l.k*l.ed.x;
}
double dis(point a,point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int cmult(point a,point b,point c)///叉积
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
point p[maxn];

int cmp(point a,point b)
{
    int ju=cmult(p[0],a,b);
    if(ju>0)return 1;
    else if(ju==0&&dis(a,p[0])<dis(b,p[0]))return 1;
    return 0;
}
int n;
int Stack[maxn],top;
void tb()
{
    point p0;
    int k=0;
    p0=p[0];
    for(int i=1;i<n;i++)
    {
        if(p0.y>p[i].y||(p0.y==p[i].y&&p0.x==p[i].x))
        {
            p0=p[i];
            k=i;
        }
    }
    swap(p[k],p[0]);
    sort(p+1,p+n,cmp);
    if(n==1)
    {
        top=0;
        Stack[0]=0;
        return ;
    }
    if(n==2)
    {
        top=1;
        Stack[0]=0;
        Stack[1]=1;
        return;
    }
    if(n>2)
    {
        top=1;
        for(int i=0;i<=1;i++)
            Stack[i]=i;
        for(int i=2;i<n;i++)
        {
            while(top>0&&cmult(p[Stack[top-1]],p[Stack[top]],p[i])<=0)
                top--;
            top++;
            Stack[top]=i;
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
        }
        tb();
        int ans=0;
        for(int i=1;i<top;i++)
        {
            ans+=abs(cmult(p[Stack[0]],p[Stack[i]],p[Stack[i+1]]));
        }
        printf("%d\n",ans/100);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值