poj-3026--Borg Maze(最小生成树(kruskal算法)+bfs(队列)

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:16245 Accepted: 5289

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
题目大意:就是在一个迷宫中有很多外星人,然后在开始去抓捕,抓捕的外星人可以分裂为无数个,求把所有外星人抓完所用的最小距离,在迷宫之中只能向东南西北四个方向移动。

思路:用搜索的方法统计出每个点(A或S)的位置,然后计算出任意两点自建的距离,然后再将其按照最小生成树的方法和模板即可算出所求最小值

代码:

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int fu[500*500];
int m,n,k;
int mark[500][500],g[500][500];
char s[500][500],s1[500];
int move_x[4]={0,0,1,-1};
int move_y[4]={1,-1,0,0};
struct ss
{
    int u,v,w;
} a[500*500];
struct node
{
    int x,y,step;
} aa,next;
int cmp(ss x,ss y)
{
    return x.w<y.w;
}
int findroot(int x)
{
    if(fu[x]!=x)
        fu[x]=findroot(fu[x]);
    return fu[x];
}
int hebing(int a,int b)
{
    int x,y;
    x=findroot(a);
    y=findroot(b);
    if(x==y)
        return 0;
    fu[y]=x;
    return 1;
}
void bfs(int x,int y,int ans)
{
    int i,j;
    memset(mark,0,sizeof(mark));
    queue<node>Q;
    aa.x=x;
    aa.y=y;
    aa.step=0;
    mark[x][y]=1;
    Q.push(aa);
    while(!Q.empty())
    {
       aa=Q.front();
        Q.pop();
        for(i=0;i<4;i++)
        {
            next.x=aa.x+move_x[i];
            next.y=aa.y+move_y[i];
            next.step=aa.step+1;
            if(next.x>=0&&next.y>=0&&next.x<n&&next.y<m&&mark[next.x][next.y]==0&&g[next.x][next.y]!=-1)
            {
                mark[next.x][next.y]=1;
                Q.push(next);
                if(g[next.x][next.y]>0)
                {
                    a[k].u=ans;
                    a[k].v=g[next.x][next.y];
                    a[k++].w=next.step;
                }
            }
        }
    }
}
int main()
{
    int test;
    scanf("%d",&test);
    while(test--)
    {
        int i,j,sum=0,u=1;
        scanf("%d%d",&m,&n);
        memset(g,0,sizeof(g));
        gets(s1);
        for(i=0;i<n;i++)
        {
            gets(s[i]);
        }
        k=0;
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(s[i][j]==' ')
                    g[i][j]=0;
                if(s[i][j]=='#')
                    g[i][j]=-1;
                if(s[i][j]=='A'||s[i][j]=='S')
                {
                    g[i][j]=u;
                    u++;
                }
            }
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(g[i][j]>0)
                    bfs(i,j,g[i][j]);
            }
        }
        for(i=0;i<=u;i++)
            fu[i]=i;
        sort(a,a+k,cmp);
        for(i=0;i<k;i++)
        {
            if(hebing(a[i].u,a[i].v))
            {
              sum+=a[i].w;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值