poj-3104

题目衔接:http://poj.org/problem?id=3104

Drying

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 25541 Accepted: 6393

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than kwater, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

 

 

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

题目大意:给你n件湿衣服,给出每件衣服的水量,再给你使用风干机每分钟能风干的水量,问你最少需要多长时间才能把说有衣服风干完

思路:二分时间,先找到最大的时间,这个不管怎么弄,最大的时间肯定不会超过这个值,然后在区间(1,max)内二分时间,判断每件衣服与当前假设时间的关系,判断如果用风干机风干需要的时间,最后判断这个时间是否正确。

代码:

/*
题目大意:给你n件湿衣服,给出每件衣服的水量,再给你使用风干机每分钟能风干的
水量,问你最少需要多长时间才能把说有衣服风干完
思路:二分
*/
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<cmath>
#include<string>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll unsigned long long
#define inf 0x3f3f3f
#define esp 1e-8
#define bug {printf("mmp\n");}
#define mm(a,b) memset(a,b,sizeof(a))
#define T() int test,q=1;scanf("%d",&test); while(test--)
const int maxn=1e6+100;
const double pi=acos(-1.0);
const int N=1100;
const int mod=1e9+7;
ll a[maxn],n,k;
bool ju(ll mid)
{
    ll tt=0;
    for(int i=0; i<n; i++)
    {
        if(a[i]>mid)
        {
            tt+=ceil((a[i]-mid)*1.0/(k-1));
        }
    }
    if(tt>mid)
        return false;
    else
        return true;
}
void b_serch(ll low ,ll high)
{
    ll mid=0,ans=0;
    while(low<=high)
    {

        mid=(low+high)/2;
        if(ju(mid))
        {
            high=mid-1;
            ans=mid;
        }
        else
            low=mid+1;
    }printf("%lld\n",ans);
}

int main()
{
    while(scanf("%lld",&n)!=EOF)
    {
        mm(a,0);
        ll m=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&a[i]);
            m=max(m,a[i]);

        }
        scanf("%lld",&k);
        if(k==1)
        {
            printf("%lld\n",m);
            continue;
        }
        b_serch(1,m);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值