华为---PPP协议简介及示例配置

PPP协议简介

        PPP是Point-to-Point Protocol的简称,中文翻译为点到点协议。与以太网协议一样,PPP也是一个数据链路层协议。以太网协议定义了以太帧的格式,PPP协议也定义了自己的帧格式,这种格式的帧称为PPP帧。

        利用PPP协议建立的二层网络称为PPP网络。一个PPP网络包含且只能包含两个PPP接口,连接这两个接口的链路称为PPP链路,这两个接口通过交互PPP帧来实现二层通信。由于一个PPP网络包含且只能包含两个PPP接口,每个接口被简化地称为一个“点”,所以一个PPP网络也经常被称为一个“点到点网络”或“P2P网络”。

        PPP接口是数据链路层(二层)通信的终结点,也就是说PPP接口是三层接口。

        PPP协议的成员协议主要包括一个 被称为LCP (Link Control Protocol) 的链路控制协议,以及一系列的被称为NCP (Network Control Protocol)的网络控制协议。
LCP:通过LCP报文的交互,本端接口会与对端接口协商若干基本而重要的参数,以确保PPP链路可以正常工作。如PPP帧中Information 字段所允许的最大长度(字节数)---MRU(Maximum Receive Unit)和错误控制。
NCP:PPP协议的本端接口会与对端接口双方会通过 NCP(Network ControlProtocol)协议来对网络层协议的参数进行协商,协商一致之后,双方才能够在PPP链路上传递携带有相应的网络层协议(如IP报文)数据单元的PPP帧。

        PPP协议对于PPP链路的长度是没有规定的。PPP链路经常应用在广域网连接中: PPP 技术被称为是一种广域网技术。

PPP链路建立基本原理

示例配置

示例要求:

  1. 通过PPP链路实现网络互通;
  2. 掌握PPP认证。

示例内容: 为了保证网络安全,服务器端链路设置PPP认证。

网络拓扑图

配置代码段

system-view 
sysname R1
interface GigabitEthernet 0/0/0
ip address 192.168.1.254 24
quit

interface Serial 4/0/0
link-protocol ppp
ip address 192.168.12.1 24
remote address 192.168.12.2
ppp authentication-mode chap domain test-d
quit
ip route-static 192.168.2.0 24 192.168.12.2
aaa
authentication-scheme test-s
authentication-mode local 
quit
domain test-yu
authorization-scheme test-s
quit
local-user test-user password cipher huawei@123
local-user test-user service-type ppp
quit

	
system-view 	
sysname R2
dhcp enable 
interface GigabitEthernet 0/0/0
ip address 192.168.2.254 24
dhcp select interface 

interface Serial 4/0/0
link-protocol ppp
ip address ppp-negotiate
ppp chap user test-user
ppp chap password cipher huawei@123
quit
ip route-static 192.168.1.0 24 192.168.12.1

代码解析

<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R1
[R1]interface GigabitEthernet 0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24
Oct 18 2023 00:02:23-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/0 has entered the UP state. 
[R1-GigabitEthernet0/0/0]quit
[R1]interface Serial 4/0/0
[R1-Serial4/0/0]link-protocol ppp
[R1-Serial4/0/0]ip address 192.168.12.1 24
[R1-Serial4/0/0]remote address 192.168.12.2 //给对端端口指定IP地址为192.168.12.2
[R1-Serial4/0/0]ppp authentication-mode chap domain test-d //设置本端的 PPP协议对对端设备的认证方式为 chap,认证采用的域名为huawei。
[R1-Serial4/0/0]quit
[R1]ip route-static 192.168.2.0 24 192.168.12.2
[R1]aaa
[R1-aaa]authentication-scheme test-s //创建认证方案test-s
Info: Create a new authentication scheme.
[R1-aaa-authen-test-s]authentication-mode local //配置认证模式为本地认证
[R1-aaa-authen-test-s]quit
[R1-aaa]domain test-yu //创建域test-yu
Info: Success to create a new domain.
[R1-aaa-domain-test-yu]authorization-scheme test-s //配置域test-yu的认证方案为test-s
Error: The authorization scheme does not exist.
[R1-aaa-domain-test-yu]quit
[R1-aaa]local-user test-user password cipher huawei@123 //配置存储在本地,为对端认证方所使用的用户名为 test-user,密码为 huawei@123。
Info: Add a new user.
[R1-aaa]local-user test-user service-type ppp //本地用户test-user 的服务类型为PPP
[R1-aaa]quit


<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname R2
[R2]dhcp enable 
Info: The operation may take a few seconds. Please wait for a moment.done.
[R2]interface GigabitEthernet 0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.2.254 24
[R2-GigabitEthernet0/0/0]dhcp select 
Oct 18 2023 00:03:20-08:00 R2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface GigabitEthernet0/0/0 has entered the UP state. 
[R2-GigabitEthernet0/0/0]dhcp select interface 
[R2-GigabitEthernet0/0/0]interface Serial 4/0/0
[R2-Serial4/0/0]link-protocol ppp
[R2-Serial4/0/0]ip address ppp-negotiate //从对端端口获取IP地址
[R2-Serial4/0/0]ppp chap user test-user //认证的用户名
[R2-Serial4/0/0]ppp chap password cipher huawei@123 //认证的密码
[R2-Serial4/0/0]quit

测试验证

PC通过DHCP获取IP地址正常

PC和服务器通信正常

  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 5
    评论
要在华为ENSP中配置PPPoE CHAP认证,可以按照以下步骤进行配置: 1. 进入接口配置视图,并选择需要配置PPPoE CHAP认证的接口。比如,假设要配置的接口是Serial4/0/0,可以使用以下命令进入接口视图: [xiaoxia_1] interface serial 4/0/0 2. 在接口配置视图中,使用以下命令来启用PPP协议,并将认证模式设置为CHAP: [xiaoxia_1-Serial4/0/0] ppp enable [xiaoxia_1-Serial4/0/0] ppp authentication-mode chap 3. 确认已经创建了本地用户,并将其服务类型设置为PPP。比如,假设要配置的本地用户是yinxiaoxia_1,可以使用以下命令进入AAA视图,并进行相应的配置: [xiaoxia_1] aaa [xiaoxia_1-aaa] local-user yinxiaoxia_1 [xiaoxia_1-aaa-local-user-yinxiaoxia_1] service-type ppp 通过以上步骤,你已经成功配置华为ENSP上的PPP CHAP认证。请注意,在实际网络环境中,可能还需要进行其他的配置和调整,以满足特定的需求。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* *3* [ppp协议(pap和chap验证模式)拓扑(eNSP)](https://blog.csdn.net/yin_CSDN_1007/article/details/124560475)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 100%"] [ .reference_list ]
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值