HDU-1856-More is better

点击打开链接


More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 28985    Accepted Submission(s): 10308


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
题意:把是朋友的放到一组,求出人数最多的那组的人数,但要注意的是由于至少要一个人,当输入为0时,输出为1;

题解:用并查集,把是朋友的放到一个集合(树)里,树的结点数为人数。

#include<stdio.h>
#include<string.h>
using namespace std;
const int MAX=1e6+10;
int par[MAX],num[MAX]; 
void init()		//初始化 
{
	for(int i=1;i<=MAX;i++)
	par[i]=i,num[i]=1;		//初始时每个节点的父亲结点为它本身//每个节点的人数为1 
}
int find(int x)	//找根节点 
{
	return x==par[x]?x:par[x]=find(par[x]);
}
int Union(int x,int y,int max)	//把是朋友的放到一个集合(树)里 ,返回值为最大人数 
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	num[fy]+=num[fx],par[fx]=fy;
	if(max<num[fy])	//返回最大人数 
	max=num[fy];
	return max;
}
int main()
{
	int T;
	while(~scanf("%d",&T))
	{
		int i,a,b;
		int max=1;	//人数最少为1 
		init();
		for(int i=1;i<=T;i++)
		{
			scanf("%d%d",&a,&b);
			max=Union(a,b,max);
		}
		printf("%d\n",max);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值