费用流解决最优匹配 PKU3686

The Windy's
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4774 Accepted: 2007

Description

The Windy's is a world famous toy factory that owns M top-class workshop to make toys. This year the manager receives N orders for toys. The manager knows that every order will take different amount of hours in different workshops. More precisely, the i-th order will take Zij hours if the toys are making in the j-th workshop. Moreover, each order's work must be wholly completed in the same workshop. And a workshop can not switch to another order until it has finished the previous one. The switch does not cost any time.

The manager wants to minimize the average of the finishing time of the N orders. Can you help him?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N and M (1 ≤ N,M ≤ 50).
The next N lines each contain M integers, describing the matrix Zij (1 ≤ Zij ≤ 100,000) There is a blank line before each test case.

Output

For each test case output the answer on a single line. The result should be rounded to six decimal places.

Sample Input

3

3 4
100 100 100 1
99 99 99 1
98 98 98 1

3 4
1 100 100 100
99 1 99 99
98 98 1 98

3 4
1 100 100 100
1 99 99 99
98 1 98 98

Sample Output

2.000000
1.000000

1.333333

#include <stdio.h>
#include <string.h>
#define CLEAR(arr, val) memset(arr, val, sizeof(arr))
#define MAXN 55
#define MAXM 3000
#define INF 0xfffffff
bool vis[MAXM];
int n, src, end, res, edge_num, cost[MAXN][MAXN], edge_head[MAXM], d[MAXM], pre[MAXM], queue[MAXM<<4];
struct Edge {
    int to, re, next, cap, cost;
} edge[MAXM*MAXM];
void add_edge(int from, int to, int cap, int cost)
{
    edge[edge_num].to = to;
    edge[edge_num].cap = cap;
    edge[edge_num].cost = cost;
    edge[edge_num].next = edge_head[from];
    edge[edge_num].re = edge_num + 1;
    edge_head[from] = edge_num++;
    edge[edge_num].to = from;
    edge[edge_num].cap = 0;
    edge[edge_num].cost = -cost;
    edge[edge_num].next = edge_head[to];
    edge[edge_num].re = edge_num - 1;
    edge_head[to] = edge_num++;
}
bool spfa()
{
    int i, p, now, next, front, rear;
    CLEAR(vis, false);
    for (i = 0; i <= end; ++i)
        d[i] = INF;
    d[src] = 0;
    front = rear = 0;
    queue[rear++] = src;
    vis[src] = true;
    while (front != rear)
    {
        now = queue[front++];
        //if (front == MAXN) // 循环队列
        // front = 0;
        vis[now] = false;
        for (p = edge_head[now]; p != 0; p = edge[p].next)
        {
             next = edge[p].to;
             if (edge[p].cap && d[next] > d[now] + edge[p].cost)
             {
                 d[next] = d[now] + edge[p].cost;
                 pre[next] = p; // 记录边的编号..通过边回溯路径
                 if (!vis[next])
                 {
                      queue[rear++] = next;
                      // if (rear == MAXN)
                      //  rear = 0;
                      vis[next] = true;
                 }
             }
        }
    }
    if (d[end] != INF)
        return true;
    return false;
}
void compute()
{
    int i, p;
    for (i = end; i != src; i = edge[edge[p].re].to)
    {
        p = pre[i];
        edge[p].cap -= 1;
        edge[edge[p].re].cap += 1;
        res += edge[p].cost;
    }
}

int main()
{
    int i, j, k, cases, m;
    scanf("%d", &cases);
    while (cases--)
    {
        edge_num = 1;
        CLEAR(edge_head, 0);
        scanf("%d%d", &n, &m);
        for (i = 1; i <= n; ++i)
            for (j = 1; j <= m; ++j)
                scanf("%d", &cost[i][j]); // 第i个任务在第j个机器上的时间
        src = 0;
        end = m * n + n + 1;
        for (i = 1; i <= n; ++i)
            add_edge(src, i, 1, 0);
        for (i = 1; i <= n; ++i) // 第i个任务
            for (j = 1; j <= n; ++j) // 对应矩阵的列
                for (k = 1; k <= m; ++k) // 对应矩阵的行
                    add_edge(i, n+(j-1)*m+k, 1, cost[i][k]*j);
        for (i = n+1; i <= m*n+n; ++i) // m*n+n!! 不要忘了前面的n个源点..
            add_edge(i, end, 1, 0);
        res = 0;
        while (spfa())
            compute();
        printf("%.6lf\n", 1.0*res/n);
    }
    return 0;
}


CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值