浙大数据结构pta——06-图2 Saving James Bond - Easy Version (25分)(详细版)

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.
Input Specification:
Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:
For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No
#include <iostream>
#include <cmath>
#define Max_Size 110
using namespace std;
int N,Matrix[Max_Size][Max_Size];
double D;
bool mark = false/*标记是否能到岸边*/,visited[Max_Size];
struct Point
{
    int x;
    int y;/*鳄鱼坐标*/
};
bool check(Point p1,Point p2,double d)/*检查能否跳到这个鳄鱼上*/
{
    double px = (p1.x - p2.x) * (p1.x - p2.x);
    double py = (p1.y - p2.y) * (p2.y - p2.y);
    double dd = sqrt(px + py);
    if(dd <= d) return true;
    else return false;
}
void dfs(int j,Point p[])
{
    if(p[j].x >= 50 - D || p[j].y >= 50 - D)/*如果可以到达终点*/
    {
        mark = true;
    }
    visited[j] = true;
    for(int i = 0 ; i <= N; i++)
    {
        if(!mark && !visited[i] && Matrix[j][i])
        {
            dfs(i,p);
        }
    }
}
int main()
{
    cin >> N >> D;
    Point p[Max_Size];/*存放每个鳄鱼的坐标*/
    p[0].x = 0;/*初始化起点*/
    p[0].y = 0;
    for(int i = 1 ; i <= N ; i++)
    {
        cin >> p[i].x >> p[i].y;
    }
    for(int i = 1; i <= N ; i++)/*先把第一个能调上去的鳄鱼找到*/
    {
        if(check(p[0],p[i],D + 7.5))
        {
            Matrix[0][i] = 1;
        }
        else
        {
            Matrix[0][i] = 0;
        }
    }
    for(int i = 1 ; i <= N; i++)/*因为第一行已经检查过所以i从1开始*/
    {
        for(int j = 0 ; j <= N; j++)
        {
            if(check(p[i],p[j],D + 7.5))/*如果能从i点的鳄鱼调到j点上去*/
            {
                Matrix[i][j] = 1;
            }
            else
            {
                Matrix[i][j] = 0;
            }
        }
    }
    dfs(0,p);
    if(mark)
    {
        cout << "Yes" << endl;
    }
    else
    {
        cout << "No" << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值