poj 1733 Parity game 【种类并查集+离散化】

Parity game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6767 Accepted: 2616

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3
分析:题意:给出一个数N代表有N个数,然后给出M组数据告诉,在某段区间内所有数的和是
奇数或偶数,找出第一组矛盾的数据。
首先要确定奇偶的传递性,即奇+偶=奇,奇+奇=偶。。。。,这样很明显是种类名并查集了,除此
之外这道题还有一点,就是离散化,由于数据比较大所以要离散化,但不能用普通离散化,要保持
区间与区间之间的正确间隔,例如区间【a,b】,可变形为【0,b】-【0,a-1】,这里要注意a-1,
a-1相对于a向后有了以为,在离散化是如果所有区间都紧挨着,则导致实际中不挨着的区间在计算式
发生重和,一次为了保证离散化的正确性,在离散化是如过实际中区间确实相邻则离散化后也一定要
相邻,如果区间不相邻则离散化后区间之间要插如一些数据以保证不发生重合详见代码。
献上代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
const int maxh=100000+10;
typedef struct Edge
{
    int u,v,w;
};
Edge E[maxh];
int fa[maxh],level[maxh],num[maxh];
bool cmp(int i1,int i2)
{
    return i1<i2;
}
void Init(int num)
{
    for(int i=0;i<=num;i++)
    {
        fa[i]=i;
        level[i]=0;
    }
}
int Find(int x)
{   
    if(x!=fa[x])
    {
        int tmp=Find(fa[x]);
        level[x]=(level[x]+level[fa[x]])%2;
        fa[x]=tmp;
    }
    return fa[x];
}
bool Union(int x,int y,int type)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx==fy)
    {
        if(((level[y]-level[x]+2)%2)==type)
        return true;
        return false;
    }
    else
    {   
        if(fx<fy)
        {
          fa[fy]=fx;
          level[fy]=(level[x]-level[y]+type+2)%2;
        }
        else
        {
            fa[fx]=fy;
            level[fx]=(level[y]-level[x]+type+2)%2;
        }
        return true;
    }
}
int main()
{
    int n,m,h,a,b,sum;
    char c[10];
    while(~scanf("%d%d",&n,&m))
    {
        h=0;
        map<int,int>mp;
        mp.clear();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%s",&E[i].u,&E[i].v,c);
            if(c[0]=='e')E[i].w=0;
            else E[i].w=1;
            if(!mp[E[i].u])
            {
                num[h++]=E[i].u;
                mp[E[i].u]=1;
            }
            if(!mp[E[i].v])
            {
                num[h++]=E[i].v;
                mp[E[i].v]=1;
            }
        }
        sort(num,num+h,cmp);
        for(int i=h-1;i>0;i--)
        if(num[i]!=num[i-1]+1)
        num[h++]=num[i-1]+1;
        sort(num,num+h,cmp);
        for(int i=0;i<h;i++)
        mp[num[i]]=i+1;
        Init(h);
        sum=m;
        for(int i=0;i<m;i++)
        {   
            if(!Union(mp[E[i].u]-1,mp[E[i].v],E[i].w))
            {   
                sum=i;
                break;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值