7-27 关于堆的判断 (25 分)
将一系列给定数字顺序插入一个初始为空的小顶堆H[]
。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root
:x
是根结点;x and y are siblings
:x
和y
是兄弟结点;x is the parent of y
:x
是y
的父结点;x is a child of y
:x
是y
的一个子结点。
输入格式:
每组测试第1行包含2个正整数N
(≤ 1000)和M
(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N
个要被插入一个初始为空的小顶堆的整数。之后M
行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:
对输入的每个命题,如果其为真,则在一行中输出T
,否则输出F
。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
题意:中文题不多解释。
题解:详细请看代码,代码里有解释。
#include <iostream>
using namespace std;
const int MAX = 1002;
int a[MAX];
int n,m;
int find(int x){//找到节点位置,即数组下标
for (int i = 1; i <= n;i++){
if(a[i]==x) return i;
}
return 0;
}
int main(){
cin >> n >> m;
for (int i = 1; i <= n;i++){//建立小顶堆
cin >> a[i];
int k=i;
while(k>1&&a[k]<a[k/2]){
swap(a[k],a[k/2]);
k/=2;
}
}
while(m--){//下面是判断各种情况,仔细看一下就好,很好理解
int x;
cin >> x;
string s;
cin >> s;
if(s=="is"){
string ss;
cin >> ss;
if(ss=="the"){
string sss;
cin >> sss;
if(sss=="root"){
if(a[1]==x) cout << "T" << endl;//a[1]就是根,看看是不是相等
else cout << "F" <<endl;
}
else{
string s1;
int xx;
cin >> s1 >> xx;
if(find(x)==find(xx)/2) cout << "T" << endl;//父亲的下标等于儿子的下标除以二
else cout << "F" << endl;
}
}
else if(ss=="a"){
string s1,s2;
int xx;
cin >> s1 >> s2 >> xx;
if(find(x)/2==find(xx)) cout << "T" << endl;//儿子的下标除以二等于父亲的下标
else cout << "F" << endl;
}
}
else if(s=="and"){
int xx;
string s1,s2;
cin >> xx >> s1 >> s2;
if(find(x)/2==find(xx)/2) cout << "T" << endl;//父亲的下标等于儿子的下标除以二,看看两个儿子的父亲是否相等,即判断两个人是不是siblings
else cout << "F" << endl;
}
}
return 0;
}