HDU ——1358 Period (kmp+循环节)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题意:给出一个字符串s,问在[0, i]区间是否有完整的循环节,看样例知道是要求最小循环节,若有,输出i并输出循环次数(循环次数要>=2);

题解:求循环节的问题,,主要还是nexts[]数组,如果nexts[i]==0说明在0——(i-1)中就一个循环节,如果nexts[i]!=0 ,那么0——(i-1)的最小循环节,就是i-nexts[i],那循环次数就是i/(i-nexts[i]). 上代码:

#include <iostream>
#include <cstring>
using namespace std;
typedef long long ll;
const int MAX = 1e6+520;
char str[MAX];
int nexts[MAX];
int l;
void getnexts(){//nexts[]模板
	//memset(nexts,0,sizeof(nexts));//初始,不初始化都对,还没碰上有错的
	int i,j;
	i=j=0;
	nexts[0]=-1;
	j=-1;
	while(i<l){
		if(j==-1||str[i]==str[j]) nexts[++i]=++j;
		else j=nexts[j];
	}
}
int main(){
	int cas=1;
	while(cin >> l,l){
		scanf("%s",str);
		cout << "Test case #" << cas++ << endl;
		getnexts();
		for (int i = 2; i <= l;i++){//注意加等号
			if(i%(i-nexts[i])||!nexts[i]) continue;//如果不是正好循环完或者只有一个循环节,跳过
		    else cout << i << " " << i/(i-nexts[i]) << endl;
		}
		cout << endl;
	}
	return 0;
}

这个题会了,可以去做一下HDU——3746   、  POJ——2406

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值