HDU——3374 String Problem (最大最小表示法+循环节+kmp)

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings: 
String Rank 
SKYLONG 1 
KYLONGS 2 
YLONGSK 3 
LONGSKY 4 
ONGSKYL 5 
NGSKYLO 6 
GSKYLON 7 
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once. 
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also. 

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

题意:求最大最小表示法,就是求一个字符串,输出左移补在右边的字典序最大和最小的下标和最小循环节循环的次数(输出一个下标输出一个次数)比如说样例第一个:

生成的字符串有:

1.abcder   2.bcdera  3.cderab  4.derabc  5.eabcdr  6.rabcde  所以字典序最小的是1  然后循环节次数是 1  然后字典序最大是6 然后循环节次数是 1  所以输出 1 1 6 1

题解:可以看出循环节循环次数,不论字典序最大还是最小,都是一样的~~这样利用 len/(len-nexts[len])就求出最小循环节循环次数了~~(len-nexts[len])它是最小循环节~然后最小最大的下标就用模板跑一下就好了~~上代码:

#include <iostream>
#include <cstring>
using namespace std;
const int MAX = 1e6+10;
char str[MAX];
int nexts[MAX];
int len;
void getnexts(){//nexts[]模板(KMP)
	//memset(nexts,0,sizeof(nexts));//初始,不初始化都对,还没碰上有错的
	int i,j;
	i=j=0;
	nexts[0]=-1;
	j=-1;
	while(i<len){
		if(j==-1||str[i]==str[j]) nexts[++i]=++j;
		else j=nexts[j];
	}
}
int posmin(int len){//最小表示法模板
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len){
        int pan=str[(i+k)%len]-str[(j+k)%len];
        if(pan==0) k++;
        else{
            if(pan>0) i+=k+1;
            else j+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i+1,j+1);
}
int posmax(int len){//最大表示法模板
    int i=0,j=1,k=0;
    while(i<len&&j<len&&k<len){
        int pan=str[(i+k)%len]-str[(j+k)%len];
        if(pan==0) k++;
        else{
            if(pan>0) j+=k+1;
            else i+=k+1;
            if(i==j) j++;
            k=0;
        }
    }
    return min(i+1,j+1);
}
int main(){
	while(~scanf("%s",str)){
		len=strlen(str);
		getnexts();
		int ci=len/(len-nexts[len]);//循环次数
		cout << posmin(len) << " " << ci << " " << posmax(len) << " " << ci << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

心脏dance

如果解决了您的疑惑,谢谢打赏呦

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值