人见人爱A^B hdoj 2035


人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22058    Accepted Submission(s): 15383


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

Sample Input
2 3
12 6
6789 10000
0 0
 

Sample Output
8
984
1
 

Author
lcy
 

Source
ACM程序设计期末考试(2006/06/07)

 

/*
最暴力:
AC
*/
/*
#include<cstdio>
#include<stdlib.h>
int main()
{
 int a,b;
 while(scanf("%d%d",&a,&b),(a||b))
 {
  int i,sum;
  for(i=1,sum=a;i<b;i++)
  {
   sum%=1000;
   sum=sum*a%1000;
     }
    printf("%d",sum%1000);
  printf("\n");
 }
return 0;
}
*/

/*
WA
*/

#include<stdio.h>
#include<stdlib.h>
/*
用递归分治写;
AC
way 1 :

int power(int a,int n)
{
 int ret;
 if(n==1)
   ret=a;
   else
   {
    
    ret=power((a%1000)*(a%1000),n/2);//分治
    if(n&1)
       ret*=a%1000;
   }
   return ret%1000;
 
}
*/

/*
用递归分治写;
AC
way 2:

int power(int a, int n)
{  
     int ret;
 if(n == 1)
    return a; 
 ret= power(a, n / 2);
 if(n&1)
 return ret * ret * a % 1000;
 else
 return ret * ret% 1000;
}
*/
/*
非递归写法;
AC
*/
int power(int a,int n)
{
 __int64 ret=1;
 while(n)
 {
  if(n&1)
    ret*=a%1000;
    a=(a%1000)*(a%1000);
    n>>=1;
 }
 return ret%1000;
}

int main()
{
 int a,b;
 while(scanf("%d%d",&a,&b),(a||b))
 {
  printf("%d\n",power(a%1000,b));// 也行
  //printf("%d\n",power(a,b)%1000);//较稳妥
  }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值