01背包系列之Bone Collector hdoj 2602

110 篇文章 0 订阅
9 篇文章 0 订阅


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29117    Accepted Submission(s): 11903


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 

Sample Output
14
 

Author
Teddy
 

Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest

/*
01背包问题:
当前最优解,要么包含第i种物品,要么不包含第i种物品
DP[i][j]表示前i个物品,背包容量为j的最优值
状态转移方程为:
DP[i][j] = max(DP[i-1][j],DP[i-1][j-v[i]] + w[i])
时间复杂度N*V , 空间复杂度N*V
空间复杂度优化:只用一位数组DP[j]来实现;
伪代码:
for i = 1 to n  //所有物品
   for j = V to v[i] //即for(j=V;j>=v[i];j--)
        dp[j] = max(dp[j] , dp[j-v[i]] + w[i]);
空间优化到一维V
原因:如果顺序遍历,一种物品会被"取"好多次

*/
#include<cstdio>
#include<string.h>
#include<stdlib.h>
int w[1000];//价值
int v[1000];//体积
int dp[1001
];//最优值 /*注意数组的大小*/
int vmax(int a,int b)
{
 return a>b?a:b;
}
int main()
{
 int T;

 scanf("%d",&T);
 while(T--)
 {
     memset(w,0,sizeof(w));
  memset(v,0,sizeof(v));
  
  int  n,m,i,j; 
  scanf("%d%d",&n,&m);
  for(i=0;i<n;i++)
  scanf("%d",&w[i]);
  for(i=0;i<n;i++)
   scanf("%d",&v[i]);
  
   memset(dp,0,sizeof(dp));
 
 for(i=0;i<n;i++)   //01背包问题的精华所在
   for(j=m;j>=v[i];j--)
    dp[j]=vmax(dp[j],dp[j-v[i]]+w[i]);
  printf("%d\n",dp[m]);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值