hdoj 1564 Play a game(博弈问题(寻找必胜点))

Play a game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1548    Accepted Submission(s): 1255


Problem Description
New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?
 

Input
The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.
 

Output
Output the winner ("8600" or "ailyanlu") for each input line except the last zero.
No other characters should be inserted in the output.
 

Sample Input
  
  
2 0
 

Sample Output
  
  
8600
 

Author
ailyanlu
 

Source
 

Recommend
8600   |   We have carefully selected several similar problems for you:  1404 1536 1524 1729 1730
/*
这道题赢家的关键就是最先抢夺过程中剩余可以走的个数为奇数的状态,总的个数为n*n刚开始可以走的个数为n*n-1,如果n为偶数n*n-1为奇数,则第一个走的人面临的就是必赢状态,否则第二走的人会赢。
*/ 
题目意思是每个人可以垂直方向走,也可以水平方向走,每回走一步,但是走过的地方就不能走了,无论怎么走都能看成转着圈走,走到中间就走不了了,奇数时走偶数步,偶数时走奇数步,所以规律就有了

#include<cstdio>

#include<cstdlib>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n),n)
{
if(n&1)
 printf("ailyanlu\n");
 else
  printf("8600\n");
}
return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值