hdoj 1719 Friend(找规律)

Friend

http://acm.hdu.edu.cn/showproblem.php?pid=1719
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2002    Accepted Submission(s): 1006


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
  
  
3 13121 12131
 

Sample Output
  
  
YES! YES! NO!
 

Source
 

/*

这道题之前我用模拟,类似斐波那契数列那样的模拟,发现有问题,后来发现找规律才是真理

思路:

假设:x 时friend number;

x=a*b+a+b

x+1=a*b+a+b+1

x+1=(a+1)(b+1);

又因为 1,2均是friend number;

所以 我们就看x+1 能否被2 3整除;

如果能被2和3整除,那么就是friend number

*/

#include<cstdio>

#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
int main()
{
int a;
while(~scanf("%d",&a))
{
 
 if(a==0)
   printf("NO!\n");
   else
     if(a==1||a==2)
      printf("YES!\n");
      else
      {
    int n=a;
    n+=1;
      while(n!=1)
        {
        if(n%2==0)
          n/=2;
         else  if(n%3==0)
          n/=3;
          else break;

        }
        if(n==1)
          printf("YES!\n");
          else
           printf("NO!\n");
  }

 

}
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值