Xamarin打开安卓设计器的那些坑

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/lhc2207221755/article/details/51140616



一,Theinstalled Android SDK is too old. Version 24.3 or newer is required


       


     之前各种配置完成之后,就去准备考试了,也没有再用,后来发现我的SDK确实是缺版本,Xamarin安装中对各个东西的版本要求其实还是蛮严格的。在Xamarin的论坛里面找到了个解决方法:


http://forums.xamarin.com/discussion/47251/the-installed-android-sdk-is-too-old-version-24-3-or-newer-is-required


  首先去: http://mirrors.neusoft.edu.cn/android/repository/  



   

       之后,放入temp文件夹,打开SDK Manager 进行安装。



二,java.lang.IllegalStateException:After scene creation, #init() must be called


java.lang.IllegalStateException: After scene creation, #init() must be called
	at com.android.layoutlib.bridge.impl.RenderAction.acquire(RenderAction.java:157)
	at com.android.layoutlib.bridge.BridgeRenderSession.render(BridgeRenderSession.java:87)
	at com.android.ide.common.rendering.api.RenderSession.render(RenderSession.java:125)
	at mono.android.DesignerSession.render(DesignerSession.java:303)
	at mono.android.DesignerSession.processMessage(DesignerSession.java:648)
	at mono.android.MessageListener.executeMessage(MessageListener.java:87)
	at mono.android.MessageListener$Runner.run(MessageListener.java:44)
	at java.lang.Thread.run(Thread.java:745)

    google的另一些答案,发现都说api 19自身有问题,只能等待google修复了,建议换成api 18或其他打开。但是我的SDK之前在eclipse里面开发安卓项目的时候是没有这个问题的,so,又打开了SDK Manager,把所有东西更了一遍,之后就没问题了。


三,关于环境搭建的一些思考


        对于.NET开发人员来说,先要配置JDK(1.7 or 1.6 32位),SDK,NDK,之后安装Xamarin到VS,如果你VS是其他版本的,估计还会出各种问题,最好是VS 15,也可以用Xamarin Studio 。对于不熟悉Java甚至不知道如何用Java开发安卓的.net人员来说,无疑要去填好多坑,而且感觉Xamarin只是起到一个中间层的作用,在生成针对各个平台的APP时候,需要单独编译的,意味着每个平台,都需要单独配置这些比较基础的环境,对于被微软宠坏了的.net程序猿们,是个挑战。但是通过Xamarin,将各个项目整合到一起,复用公共部分,想法还是不错的。











展开阅读全文

没有更多推荐了,返回首页