A - Super Mobile Charger

While HIT ACM Group finished their contest in Shanghai and is heading back Harbin, their train was delayed due to the heavy snow. Their mobile phones are all running out of battery very quick. Luckily, zb has a super mobile charger that can charge all phones.

There are N people on the train, and the i-th phone has p[i] percentage of power, the super mobile charger can charge at most M percentage of power.

Now zb wants to know, at most how many phones can be charged to full power. (100 percent means full power.)

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, the first line contains two integers N, M(1 <= N <= 100,0 <= M <= 10000) , the second line contains N integers p[i](0 <= p[i] <= 100) meaning the percentage of power of the i-th phone.

Output

For each test case, output the answer of the question.

Sample Input
2
3 10
100 99 90
3 1000
0 0 0
Sample Output
2
3

题目大意:在火车上需要给手机充电,现在有一个容量为power的充电宝给手机充电问最多能充多少个?

代码



#include <iostream>
#include <cstdio>
#include <cstring>
#include<set>
#include <vector>
#include <cmath>
#include <algorithm>
#include <string>
using namespace std;
int a[105];
bool cmp(int x,int y)
{
    return x<y;
}
int main()
{
    int repeat;
    while(scanf("%d",&repeat)!=EOF)
    {
        while(repeat--)
        {
            int num,power;
            int count1=0;
            scanf("%d%d",&num,&power);
            for(int i=0;i<num;i++)
                scanf("%d",&a[i]);
            sort(a,a+num,cmp);//这里就是对那些手机的剩余电进行排序
            for(int i=num-1;i>=0;i--){
                if(a[i]==100)
                    count1++;
                else
                if((power+a[i])>=100){
                    count1++;
                    power=power-(100-a[i]);
                }
            }
            printf("%d\n",count1);
    }
}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值