poj3276:Face The Right Way

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

题目大意
N头牛排成一列。每头牛或者向前或者向后。有一台自动转向的的机器,这个机器在购买时必须设定一个数值K,机器每操作一次恰好使K头连续的牛转向。求出让所有牛都能面向前方需要的最少的操作次数M和对应的最小的K。

解题思路:
这是一道典型的开关问题。首先要明确开关问题需满足的条件:
①.若某一个位置被翻转了n次,则其实际上被翻转了n%2次,因为翻转2k次相当与没翻转,翻转2k+1次相当于翻转了1次,因为要求最小翻转次数,所以对于某一个位置要么只(主动)翻转一次,要么不(主动)翻转。
②分析易知翻转的顺序并不影响最终结果。(理解不了可自己举个例子在纸上模拟下)
我们首先考虑最左边牛的情况。由题意可知,这头牛最后的状态仅由是否反转它本身决定(若它本身向前,则不需反转,否则必须反转),从左向右依此类转。由此可知,当K值确定时,翻转次数与最终状态实际上已经确定,所以我们只需将K值遍历一遍即可得出最终结果。
在求区间反转部分时还可进行有如下优化:
定义f[i]:=区间[i,i+k-1]进行了反转的话则为1,否则为0
这样,在考虑第i头牛时,如果sum f【j】(j=i-K+1,…,i-1)为奇数,则这头牛的方向与起始方向相反,否则方向不变。

代码如下:


#include<iostream>
#include<memory.h>
using namespace std;
int N;
int dir[5005];
int f[5005];//记录牛是否转向
void solve();
int calc(int K);
int main()
{
    int i;
    char s;
    while(cin>>N)
    {
        for(i=0;i<N;i++)
        {
            cin>>s;
            if(s=='F')
            dir[i]=0;
            else
            dir[i]=1;
        }
        solve();    
    }
    return 0;
}
void solve()
{
    int K=1,M=N;
    for(int k=1;k<=N;k++)
    {
        int m=calc(k);
       if(m>=0&&M>m)
       {
        M=m;
        K=k;
       }
    }
    cout<<K<<" "<<M<<endl;
}
int calc(int K)
{
    memset(f,0,sizeof(f));
    int res=0;
    int sum=0;
    for(int i=0;i+K<=N;i++)
    {
        if((dir[i]+sum)%2!=0)//判断第i头牛是否面朝前
        {
            res++;
            f[i]=1;
        }
        sum+=f[i];
        if(i-K+1>=0)
        sum-=f[i-K+1];
    }
    for(int i=N-K+1;i<N;i++)//检查剩下的牛是否都面朝前
    {
        if((dir[i]+sum)%2!=0)
        return -1;
        if(i-K+1>=0)
        sum-=f[i-K+1];
    }
    return res;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值