Boolean expressions

描述
The objective of the program you are going to produce is to evaluate boolean expressions as the one shown next:
Expression: ( V | V ) & F & ( F | V )

where V is for True, and F is for False. The expressions may include the following operators: ! for not , & for and, | for or , the use of parenthesis for operations grouping is also allowed.

To perform the evaluation of an expression, it will be considered the priority of the operators, the not having the highest, and the or the lowest. The program must yield V or F , as the result for each expression in the input file.

输入
The expressions are of a variable length, although will never exceed 100 symbols. Symbols may be separated by any number of spaces or no spaces at all, therefore, the total length of an expression, as a number of characters, is unknown.

The number of expressions in the input file is variable and will never be greater than 20. Each expression is presented in a new line, as shown below.

输出
For each test expression, print “Expression ” followed by its sequence number, “: “, and the resulting value of the corresponding test expression. Separate the output for consecutive test expressions with a new line.

Use the same format as that shown in the sample output shown below.

样例输入
( V | V ) & F & ( F| V)
!V | V & V & !F & (F | V ) & (!F | F | !V & V)
(F&F|V|!V&!F&!(F|F&V))

样例输出
Expression 1: F
Expression 2: V
Expression 3: V

来源
México and Central America 2004

题目大意
给你一个布尔表达式,判断表达式是否为真。

解题思路
使用递归,完全模拟逆波兰表达式算法。但是要注意细微的差别,在factor_bool()函数中,除了出现“(”,“V”,”F”外,还有可能会出现“!”,此时要递归进入term_bool()函数中去。
代码如下:

#include<iostream>
#include<string>
#include<cstring>
using namespace std;
char s[100005]={0};
int cnt=0;
bool expression_bool();
bool term_bool();
bool factor_bool();
int main()
{
    int k=0;
    while(cin.getline(s,100000))
    {
        char t[100001]={0};
        int len=strlen(s);
        for(int i=0,k=0;i<len;i++)
        {
            if(s[i]!=' ')
            t[k++]=s[i];
        }

    len=strlen(t);
    for(int i=0;i<len;i++)
    s[i]=t[i];
    s[len]='\0';

    cout<<"Expression "<<++k<<": "<<(expression_bool()?"V":"F")<<endl;
    cnt=0;
    memset(s,0,sizeof(s));
   }
    return 0;
} 
bool expression_bool()
{
    bool result=term_bool();
    bool more =true;
    while(more)
    {
        char op=s[cnt];
        if(op=='&'||op=='|')
        {
            cnt++;
            bool value=term_bool();
            if(op=='&')
            result=result&value;
            else
            result=result|value;
        }
        else
        more=false;
    }
    return result;

}
bool term_bool()
{
    bool result;
    char op=s[cnt];
    if(op=='!')
    {
        cnt++;
        result=!factor_bool();
    }
    else
    result=factor_bool();
    return result;
}
bool factor_bool()
{
    bool result;
    char c=s[cnt];
    if(c=='(')
    {
        cnt++;
        result=expression_bool();
        cnt++;
    }
    else if(c=='V')
    {
        result=true;
        cnt++;
    }
    else if(c=='F')
    {
        result=false;
        cnt++;
    }
    else if(c=='!')
    result=term_bool();

    return result;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值