dfs_1155 Heap Paths (30 分)

该博客主要介绍了PAT考试中的1155题——Heap Paths,讨论如何检查一棵完全二叉树是否满足最大堆或最小堆的条件。博主通过层次遍历的方法,按照先右子节点后左子节点的顺序输出所有从根到叶的路径,并在最后判断树是最大堆、最小堆还是非堆。
摘要由CSDN通过智能技术生成

目录

1155 Heap Paths

题目描述

解题思路

程序


1155 Heap Paths

题目描述

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

解题思路

题目按照层次遍历给出一棵树,要求输出所以根节点到叶子节点的路径,先遍历右子节点,后遍历左子节点,最后指出为大顶堆、小顶堆、或者什么都不是

在dfs遍历树的时候,要考虑的有可能右子节点不存在,但是左子节点存在的情况,所以在连接两个遍历之间不能使用else,应为

    if(pos*2+1 <= n)
        dfs(pos*2+1),ans.pop_back();
    if(pos*2 <= n)
        dfs(pos*2),ans.pop_back();

 这样即可以保证右子节点不存在,但是仍然可以遍历到左子节点

判断大顶堆或者小顶堆判断输出的跟节点到叶子节点的顺序由大到小还是由小到大

程序

#include <iostream>
#include <initializer_list>
#include <algorithm>
#include <string>
#include <string.h>
#include <thread>
#include <cmath>
#include <vector>
#include <unordered_map>
#include <set>
#define INF 0x3f3f3f3f

using namespace std;
const int maxn = 1000+5;
int n,node[maxn];
vector<int> ans;
bool flag1 = 1,flag2 = 1;

void dfs(int pos)
{
    ans.push_back(pos);
    if(pos*2 > n)
    {
        for(int i =0 ;i < ans.size();i ++)
        {
            if(i != 0)
            {
                if(node[ans[i]] > node[ans[i-1]]) flag1 = 0;
                if(node[ans[i]] < node[ans[i-1]]) flag2 = 0;
            }
            printf("%d%c",node[ans[i]],i==ans.size()-1?'\n':' ');
        }
        return ;
    }

    if(pos*2+1 <= n)
        dfs(pos*2+1),ans.pop_back();
    if(pos*2 <= n)
        dfs(pos*2),ans.pop_back();
}
int main()
{
    scanf("%d",&n);
    for(int i =1 ;i <= n;i ++)
        scanf("%d",node+i);
    dfs(1);

    if(flag1)
        printf("Max Heap\n");
    else if(flag2)
        printf("Min Heap\n");
    else
        printf("Not Heap\n");

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值