6-8 在升序链表中添加新结点

本题要求实现,将输入的学生信息组成单向链表(要求按学号由小到大的顺序输入学生信息);添加一个新的学生信息,并保持学生信息仍然按学号由小到大的顺序。

函数接口定义:

struct stud_node *create();
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s );

函数create利用scanf从输入中获取一系列正整数,当读到0时表示输入结束。要求按学号由小到大的顺序输入学生信息。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define LEN sizeof(struct stud_node)

struct stud_node {
     int    num;
     char   name[20];
     int    score;
     struct stud_node *next;
};

struct stud_node *create();
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s );

int main()
{
    int  num,score;
    char name[20];
     struct stud_node *p, *head = NULL;
     head = create();
     scanf("%d%s%d",&num,name,&score);
      head=insertdata(head,num,name,score);
     for ( p = head; p != NULL; p = p->next )
        printf("%d %s %d\n", p->num, p->name, p->score);
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例1:

10001 zhang 96
10003 wang 63
0
10002 liu 100

输出样例1:

10001 zhang 96
10002 liu 100
10003 wang 63

输入样例2:

10001 zhang 96
10002 liu 100
10003 wang 63
0
10004 zhao 90

输出样例2:

10001 zhang 96
10002 liu 100
10003 wang 63
10004 zhao 90

输入样例3:

10001 zhang 96
10002 liu 100
10003 wang 63
10004 zhao 90
0
10000 sun 95

输出样例3:

10000 sun 95
10001 zhang 96
10002 liu 100
10003 wang 63
10004 zhao 90

 

struct stud_node *create()
{
    struct stud_node *p,*i,*o;
    p=i=(struct stud_node *)malloc(sizeof(struct stud_node));
    scanf("%d",&p->num);
    o=p;
    while(p->num!=0)
    {
        scanf("%s %d",p->name,&p->score);
        i=p;
        p=(struct stud_node *)malloc(sizeof(struct stud_node));
        i->next=p;
        scanf("%d",&p->num);
    }
    i->next=NULL;
    return(o);
}
struct stud_node *insertdata( struct stud_node *head, int n,char name[],int s )
{
    struct stud_node *p,*o,*i;
    int c=0;
    p=head;
    o=(struct stud_node *)malloc(sizeof(struct stud_node));
    o->num=n;
    strcpy(o->name,name);
    o->score=s;
    if(p->num>o->num)
    {
       o->next=p;
        head=o;
        return(head);
    }
    i=p;
    p=p->next;
    while(p!=NULL)
    {
        if(p->num>o->num)
        {
            o->next=p;
            i->next=o;
            c=1;
            break;
        }
        i=p;
        p=p->next;
        
    }
    if(c==1)
        return(head);
    i->next=o;
    o->next=NULL;
    return(head);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值