链表——删除指定元素

链表-删除指定元素

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
       对于一个给定的线性表,要求删除线性表内的大于等于 min 且小于等于 max 的数,并输出删除后的线性表
要求:必须使用链表做,否则不计成绩
Input

        输入的第一行为一个正整数 T,表示有 T 组测试数据。
        每组测试数据的第一行为三个整数n、min、max,表示有 n 个数据,删除的范围为[min, max].第二行为 n 个整数代表初始的 n 个数据。

Output
         输出删除数据后的线性表,如果线性表为空则输出-1

Example Input
2
3 1 2
1 2 3
5 2 1
1 1 1 1 1
Example Output
3
1 1 1 1 1
Hint
 
Author
gaoyongxin
#include<iostream>
#include<stdio.h>
using namespace std;
struct Lnode
{
    int data;
    Lnode * next;
};
Lnode * del(Lnode * head,int a, int b)
{
    Lnode * tail;
    tail=head;
    while(head->next)
    {
        if(head->next->data>=a && head->next->data<=b)
        {
           head->next=head->next->next;
        }
        else
        head=head->next;
    }
    return tail;

}
int main()
{
    int t;
    int n,min,max;
    cin>>t;
    while(t--)
    {
       cin>>n>>min>>max;
       Lnode * head, * tail , * liste;
       head=new Lnode;
       head->data=0;
       head->next=NULL;
       tail=head;
       while(n--)
       {
           int a;
           cin>>a;
           liste=new Lnode;
           liste->data=a;
           liste->next=NULL;
           tail->next=liste;
           tail=liste;
       }
       head=del(head,min,max);
       if(head->next==NULL)
       {
           cout<<"-1"<<endl;
       }
       else
       {
           head=head->next;
           while(head->next)
           {
               cout<<head->data<<" ";
               head=head->next;
           }
           cout<<head->data<<endl;
       }
    }

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值