Stripies

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn’t equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2sqrt(m1m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.

Input
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

题意:给你n个物体,分别给出n个物体的质量,并且两个物体(假设两个物体质量为m1,m2)碰撞变成一个物体,质量为2*sqrt(m1*m2),并且只会出现两个物体碰撞的情况,问最终得到的物体的最小质量是多少。

题目分析:
这也是一道贪心题目,因为每碰撞得到的质量都是由开根号得到的,而越大的数开根号后的减小量就越大,因此应该先让质量大的物体去碰撞。这就是这道题的贪心方法。
为了让每次碰撞都取到最大值,因此我们可以用大根堆来做。

代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map> 
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=200;
using namespace std;
int main()
{
	int n;
    cin>>n;
	priority_queue<double> heap;  //定义大根堆
	for(int i=1;i<=n;i++)//输入数据
	{
		double x;
		cin>>x;
		heap.push(x);
	}
	while(heap.size()>1) //当堆中只有一个元素时停止(即所有物体都碰成一个)
	{
		double a,b;
		a=heap.top();
		heap.pop();
		b=heap.top();
		heap.pop();
		heap.push(2*sqrt(a*b)); //让质量最大的和第二大的相撞
	}
	printf("%.3f",heap.top());//输出结果
	return 0;                 //注意要用float格式输出,不然会谜之wa   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lwz_159

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值