Monkey and Banana

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目大意:
给你n种长方体(每种长方形数目不限),并给出它的三边长,让你求出用这些长方体堆成塔型的最大高度。(要求:塔下面的长方体的长和宽必须大于上面的长方体)

思路:

  1. 每种长方体都都有三种放法:分别以x,y,z为高。因此我们要先处理一下输入的数据。
  2. 处理好了输入之后,就开始找状态了,这道题其实就是一个最长上升子序列问题。我们可以用f[i] //前i种处理完的长方体所摆成的最大高度表示状态。
  3. 因为有两个参数(长和宽)因此我们要先固定一个参数,按x从小到大进行排序。这样这道题就转化为了一道最长上升子序列的问题。
  4. 状态方程为:当a[i].x<a[j].x&&a[i].y<a[j].y时,f[i]=max(f[i],f[j]+a[i].h)

最长上升子序列

ac代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=1e3+5,mod=1e9+7;
using namespace std;
struct Node{
	int x,y,h;     //x长,y宽,h高
	bool operator< (Node const &a) const  //排序准则
	{                                     //按x从小到大排序
		if(x!=a.x) return x<a.x;
		return y<a.y; 
	}
}a[N]; 
int f[N];
int main()
{
	int n,k=0;
	while(cin>>n,n)     //输入多组数据
	{
		memset(f,0,sizeof f);   //清空f数组
		int m=0;
		while(n--)      //对输入数据进行处理
		{
			int x,y,z;
			cin>>x>>y>>z;
			m++;
			a[m].x=max(x,y),a[m].y=min(x,y),a[m].h=z;
			m++;
			a[m].x=max(y,z),a[m].y=min(y,z),a[m].h=x;
			m++;
			a[m].x=max(x,z),a[m].y=min(x,z),a[m].h=y;
		}
		sort(a+1,a+1+m);
		
		int ans=0;
		for(int i=m;i>=1;i--)
		{
			f[i]=a[i].h;     //初始化
			for(int j=i+1;j<=m;j++)
			if(a[i].x<a[j].x&&a[i].y<a[j].y)
			f[i]=max(f[i],f[j]+a[i].h);
			ans=max(ans,f[i]);   //ans记录f[i]中的最大值
		}
		cout<<"Case "<<++k<<": maximum height = "<<ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lwz_159

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值