Jumping Cows(线性DP)

Farmer John’s cows would like to jump over the moon, just like the cows in their favorite nursery rhyme. Unfortunately, cows can not jump.
The local witch doctor has mixed up P (1 <= P <= 150,000) potions to aid the cows in their quest to jump. These potions must be administered exactly in the order they were created, though some may be skipped.
Each potion has a ‘strength’ (1 <= strength <= 500) that enhances the cows’ jumping ability. Taking a potion during an odd time step increases the cows’ jump; taking a potion during an even time step decreases the jump. Before taking any potions the cows’ jumping ability is, of course, 0.
No potion can be taken twice, and once the cow has begun taking potions, one potion must be taken during each time step, starting at time 1. One or more potions may be skipped in each turn.
Determine which potions to take to get the highest jump.

Input

  • Line 1: A single integer P
  • Lines 2…P+1: Each line contains a single integer that is the strength of a potion. Line 2 gives the strength of the first potion; line 3 gives the strength of the second potion; and so on.

Output

  • Line 1: A single integer that is the maximum possible jump.

Sample Input
8
7
2
1
8
4
3
5
6
Sample Output
17

题目大意:牛不会跳,为了让让牛跳的更高,有n瓶药。这些药必须按顺序给出,其中某些药可以跳过不用。用的药是奇数瓶时,牛跳跃的高度的会加a[i];而如果药是偶数瓶时,牛跳跃的高度的会减a[i]。问怎么安排用药能让牛跳的最高。

题目分析:

  1. 状态表示:因为奇数次用药和偶数次用药的效果是不同的,因此有两种状态:
    f[i][0] //表示1-i瓶药使牛达到的最大高度是多少,且最后一次用药是偶数次
    f[i][1] //表示1-i瓶药使牛达到的最大高度是多少,且最后一次用药是奇数次
  2. 状态计算:
    f[i][0]=max(f[i-1][0],f[i-1][1]-a[i]) //寻找f[i-1][0]和f[i-1][1]-a[i]的最大值即可。注意:当选取第i瓶药时,因为最后一次取药为偶数次,因此上一次要是奇数次(即:f[i-1][1])
    同理可得,f[i][1]=max(f[i-1][1],f[i-1][0]+a[i])

ac代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
#include <iomanip>
#define LL long long
const int N=2e5+5;
using namespace std;
int a[N],f[N][2];
int main()
{
	int n;
	while(cin>>n)
	{
	    for(int i=1;i<=n;i++)
	    cin>>a[i];
	    for(int i=1;i<=n;i++)
	    {
		    f[i][1]=max(f[i-1][1],f[i-1][0]+a[i]);
		    f[i][0]=max(f[i-1][0],f[i-1][1]-a[i]);
	    }
	    cout<<f[n][1]<<endl;
    }
	return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lwz_159

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值