刚哥遇到了感情问题(二)

题目:

刚哥遇到了感情问题(二)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

上一集我们讲到 作为工作室老大的刚哥遇到很多女生的追求,你帮他个挑选了个英语成绩不错的对象。在你的帮助下,刚哥找到了个    英语学霸村    的小花,刚哥对小花的追求并不是那么一帆风顺。

事情是这样的:为了追求小花,刚哥打算给小花写点情书,然而小花却要求刚哥用英文给她写情书,并且要求刚哥不许使用百度翻译,这可难为刚哥了,刚哥自幼就爱国,对西洋文不怎么感冒,幸得健爷的帮助,刚哥成功把中文的情书翻译成了英文的情书,然而问题来了,刚哥写的情书太肉麻,健爷决定把   miss  love  kiss  这三个单词替换成  apple  banana  orange  ,眼看着今晚就要约会了,没有这些肉麻的词,刚哥约会时会不自在的.

你能在今晚10点前帮刚哥把信里面出现这三个单词的地方合理地用  miss  love  kiss  替换吗?刚哥都快急哭了,你就帮帮他吧  O(∩_∩)O~

输入
多组输入

一次输入多行

情书以 thas all 结束
程序 读到文档结束。
输出
帮刚哥把信里面出现这三个单词的地方合理地用 miss love kiss 替换, 原格式输出。
样例输入
Dear Mine: Just for one reason, I banana you so much. Nothing is impossible to a willing mind, banana included. Therefore, day after day, I wonder why, I wonder how, I wonder where you are. Time to go, I want to tell you how much I feel, and how much I banana you. When I think of you, the miles between us disappear. Seeing you will cause me an indescribable thrill, even at the sight of your handwriting will make me tremble. And the wonderful times we shared together shall always remain in my heart. You are my little angel. Just having you close fills me with banana and hope; nothing is impossible by your side. It is only when I nearly lose you that I become fully conscious of how much I value you. Accordingly, I would say, "I banana you" for millions and billions of times, and times and times again. Everything comes and goes, but banana stays. When you need someone, remember that I'd be there. If I were in heaven, I'd write your name on every star for all to see just how much you mean to me. No matter how long the road may be in the future, please cherish every moment we shared together. No matter how many years will pass away, please treasure our banana till the last day. banana is the triumph of imagination over intelligence.thas alli apple youi banana youi orange youthas all
样例输出
Dear Mine: Just for one reason, I love you so much. Nothing is impossible to a willing mind, love included. Therefore, day after day, I wonder why, I wonder how, I wonder where you are. Time to go, I want to tell you how much I feel, and how much I love you. When I think of you, the miles between us disappear. Seeing you will cause me an indescribable thrill, even at the sight of your handwriting will make me tremble. And the wonderful times we shared together shall always remain in my heart. You are my little angel. Just having you close fills me with love and hope; nothing is impossible by your side. It is only when I nearly lose you that I become fully conscious of how much I value you. Accordingly, I would say, "I love you" for millions and billions of times, and times and times again. Everything comes and goes, but love stays. When you need someone, remember that I'd be there. If I were in heaven, I'd write your name on every star for all to see just how much you mean to me. No matter how long the road may be in the future, please cherish every moment we shared together. No matter how many years will pass away, please treasure our love till the last day. love is the triumph of imagination over intelligence.thas alli miss youi love youi kiss youthas all


心得:

找到apple的位置,str[]中apple前的字符加上'\0'组成新串stra[],apple后的字符串组成新串strb[],然后将stra和"love"连接,形成新串,再将这个与strb[]连接,形成新串,再把这个串复制给str,再找下一个apple,找完apple后,找banana……,最终str[]变成替换后的新衣服串
关键步骤:
1.apple的位置,编写函数BF(),返回其位置
2.用循环完成重复查找是否有apple,banana,orange
3.在循环中不断形成新串str(用赋值完成,但是浪费时间),对str进行重复查找,直到文件结束

代码<c语言>

 #include<stdio.h>
#include<string.h>
 int BF1(char str[],char str1[]);
 int BF2(char str[],char str2[]);
 int BF3(char str[],char str3[]);
 int BF4(char str[],char strf[]);
int main()
{
int i,j,a,k,count;
char str[1000];
char stra[1000];
char strb[1000];
char str1[]="apple";
char str2[]="banana";
    char str3[]="orange";
char str4[]="miss";
char str5[]="love";
    char str6[]="kiss";
    freopen("AAA.txt","r",stdin);
     while(gets(str)){
            //循环,直到没有字符串,即文件结束
     a=BF1(str,str1);
     while(a!=0){
     for(i=0;i<a-1;i++)//apple前的字符组成的字符串stra[]
     {
     stra[i]=str[i];
     }
     stra[i]='\0';
        j=0;
     for(i=a+4;str[i]!='\0';i++)//apple后的字符组成的字符串strb[]

     {
     strb[j]=str[i];
     j++;
     }
     strb[j]='\0';
     strcat(stra,str4);
     strcat(stra,strb);
i=0;
while(stra[i]!='\0')
{
str[i]=stra[i];
i++;
}
 str[i]='\0';//将新生成的字符串复制给str[]
a=BF1(str,str1);//继续找是否有apple
}
 a=BF2(str,str2);
while(a!=0){
     for(i=0;i<a-1;i++)//banana前的字符组成的字符串stra[]
     {
     stra[i]=str[i];
     }
     stra[i]='\0';
        j=0;
     for(i=a+5;str[i]!='\0';i++)//banana后的字符组成的字符串strb[]

     {
     strb[j]=str[i];
     j++;
     }
     strb[j]='\0';
       strcat(stra,str5);
     strcat(stra,strb);
i=0;
while(stra[i]!='\0')
{
str[i]=stra[i];
i++;
}
 str[i]='\0';//将新生成的字符串复制给str[]
a=BF2(str,str2);//继续找是否有banana
}
 a=BF3(str,str3);
     while(a!=0){
     for(i=0;i<a-1;i++)//orange前的字符组成的字符串stra[]
     {
     stra[i]=str[i];
     }
     stra[i]='\0';
        j=0;
     for(i=a+5;str[i]!='\0';i++)//orange后的字符组成的字符串strb[]

     {
     strb[j]=str[i];
     j++;
     }
     strb[j]='\0';
  strcat(stra,str6);
     strcat(stra,strb);
i=0;
while(stra[i]!='\0')
{
str[i]=stra[i];
i++;
}
 str[i]='\0';//将新生成的字符串复制给str[]
a=BF3(str,str3);//继续找是否有orange
}
printf("%s\n",str);
}
   return 0;
   }

     int BF1(char str[],char str1[])//BF算法 a为主串,b为被检验的串,返回b在a中的第一个位置,若无返回0
{
int i=0,j=0;
char b[1000] ;
while (str[i]&&str1[j])
 if (str[i++]==str1[j]) ++j;//继续比较后继字
else  {
    i-=j;
    j=0;
    }
return !j||str1[j]?0:i-j+1;
}
   int BF2(char str[],char str2[])//BF算法 a为主串,b为被检验的串,返回b在a中的第一个位置,若无返回0
{
int i=0,j=0;
char b[1000] ;
while (str[i]&&str2[j])
 if (str[i++]==str2[j]) ++j;//继续比较后继字
else  {
    i-=j;
    j=0;
    }
return !j||str2[j]?0:i-j+1;
}
  int BF3(char str[],char str3[])//BF算法 a为主串,b为被检验的串,返回b在a中的第一个位置,若无返回0
{
int i=0,j=0;
char b[1000] ;
while (str[i]&&str3[j])
 if (str[i++]==str3[j]) ++j;//继续比较后继字
else  {
    i-=j;
    j=0;
    }
return !j||str3[j]?0:i-j+1;
}
  int BF4(char str[],char strf[])//BF算法 a为主串,b为被检验的串,返回b在a中的第一个位置,若无返回0
{
int i=0,j=0;
char b[1000] ;
while (str[i]&&strf[j])
 if (str[i++]==strf[j]) ++j;//继续比较后继字
else  {
    i-=j;
    j=0;
    }
return !j||strf[j]?0:i-j+1;
}



深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值