poj3278 线上的BFS搜索

7 篇文章 0 订阅
4 篇文章 0 订阅

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74493 Accepted: 23486

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

了解还不是很深入,开始用DFS一直WA,直到请教了学长跟我说最短路最好还是用DFS。

传送门

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

int m,sp=0;

struct node
{
    int x;
    int sum;
}t,tt;

queue<node> Q;
int vis[112345];

bool ff(int x)
{
    if(x<0||x > 100000||vis[x]) return false;
    return true;
}

void bfs()
{
    while(!Q.empty())
    {
        tt=Q.front();
        Q.pop();
        if(tt.x==m)
        {
            cout<<tt.sum<<endl;
            break;
        }
        if(ff(tt.x-1))
        {
            t={tt.x-1,tt.sum+1};
            Q.push(t);
            vis[tt.x-1]=1;
        }
        if(ff(tt.x+1))
        {
            t={tt.x+1,tt.sum+1};
            Q.push(t);
            vis[tt.x+1]=1;
        }
        if(ff(tt.x*2))
        {
            t={tt.x*2,tt.sum+1};
            Q.push(t);
            vis[tt.x*2]=1;
        }
    }
}
int main()
{
    int n;
    memset(vis,0,sizeof(vis));
    cin>>n>>m;
    t={n,0};
    Q.push(t);
    vis[n]=1;
    bfs();
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值