【PTA题库】1001 A+B Format (20分)

Q:
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9 

Sample Output:

-999,991

CODE:

#include <iostream>
#include <cmath>

using namespace std;

/*子函数打印三个数字比如1001%1000 ==1 后打印为001*/
void print_3nums(int nums) {
	if (nums == 0)
		cout << "000";
	else if (nums >= 100)
		cout << nums;
	else if (nums >= 10)
		cout << '0' << nums;
	else
		cout << "00" << nums;
}

int main()
{
	int a, b;
	cin >> a >> b;
	int sum = a + b;
	if (sum < 1000 && sum > -1000)
		cout << sum;
	else if (sum < 1000000 && sum > -1000000) {
		cout << sum / 1000 << ',';
		sum = abs(sum % 1000);//abs为取绝对值,包含在cmath头文件
		print_3nums(sum);
	}
	else {
		cout << sum / 1000000 << ',';
		sum = abs(sum);
		print_3nums(sum % 1000000 / 1000);
		cout << ',';
		print_3nums(sum % 1000);
	}

	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值