题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出
3
10
7
解题思路
由于题目给出了相当大可能的测试组数,若采用每个测试数组都重复累加计算必然会超时。因此生成一个dist数组来存储1号出口到任意出口的单向距离。由此x号出口到y号出口的距离可以转换成各自到1号出口的距离之差。然后通过整个圆的距离相减,来判断反向距离是否更近。
代码
#include <iostream>
int main()
{
int n;
int a[100000];//本程序从0号存储数据,a[i]代表i-1号出口到i号出口的距离
int dist[100000];//1到各节点的距离数组
int sumdist = 0;//大圈的距离
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%d", a + i);
sumdist += a[i];
if (i)
dist[i] = dist[i - 1] + a[i - 1];
else
dist[i] = 0;
}
int M;
scanf("%d", &M);
while (M--) {
int x, y, dist1 = 0;
scanf("%d %d", &x, &y);
if (x > y) {
int temp = x;
x = y;
y = temp;
}
x--;//从1-N转换成相应的0~(N-1)
y--;
printf("%d\n", 2 * (dist[y] - dist[x]) < sumdist ? dist[y] - dist[x] : sumdist - dist[y] + dist[x]);
}
return 0;
}