绘制图形

95 篇文章 0 订阅
87 篇文章 0 订阅

/*问题描述
 找出下面给出图形的规律,给出n,画一个n行的对应图形。
 1 2 3 4
 12 13 14 5
 11 16 15 6
 10 9 8 7
 输入格式
 输入包含一个数n。1<=n<=30
 输出格式
 输出与上图类似n行的图形。
 样例输入
 4
 样例输出
 1 2 3 4
 12 13 14 5
 11 16 15 6
 10 9 8 7*/
import java.util.*;

public class Main {
	public static int n;
	public static int[][] array;

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		n = sc.nextInt();
		array = new int[n][n];
		int i = 0, j = -1, result = 0;
		while (result < n * n) {
			// System.out.println(result);
			while (j + 1 < n && array[i][j + 1] == 0) {
				array[i][++j] = ++result;
			}
			while (i + 1 < n && array[i + 1][j] == 0) {
				array[++i][j] = ++result;
			}
			while (j - 1 >= 0 && array[i][j - 1] == 0) {
				array[i][--j] = ++result;
			}
			while (i - 1 > 0 && array[i - 1][j] == 0) {
				array[--i][j] = ++result;
			}
		}
		sc.close();
		for (int k = 0; k < n; k++) {
			for (int m = 0; m < n; m++) {
				System.out.print(array[k][m] + " ");
			}
			System.out.println();
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值