杭电1017



水题,但格式问题很重要,


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 


Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 


Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 


Sample Input
  
  
1 10 1 20 3 30 4 0 0
 


Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5

注意 !(n==0 && m==0)与n!=0&&m!=0不一样 ,这个点导致在oj上怎么都过不了 

求问:
 疑惑????按题目意思应该是n!=0&&m!=0时程序退出

我用n!=0&&m!=0在杭电oj上怎么都过不了,提示答案错误,用 !(n==0 && m==0)就通过了,两者前者不应该更符合题意吗?

我的代码

#include<stdio.h>
int find_sum(int,int);
int main()
{
	int N, n, m, sum;
	
	scanf("%d", &N);  //测试模块数量
	int temp=N-1;
	int i = 1;
	//printf("\n");
	while (N != 0) {
		N--;
		if(N<temp)
		   printf("\n");  //此题注意格式问题,每个输出块之间都空一行 
		 i = 1;
		scanf("%d%d", &n, &m);
		while (!(n==0 && m==0)) {          //注意 !(n==0 && m==0)与n!=0&&m!=0不一样 
			sum=find_sum(n,m);
			printf("Case %d: %d\n",i,sum);
			i++;

			scanf("%d%d", &n, &m);

		}
//		N--;
//		if(N>0) 
//		   printf("\n");
	}
	return 0;
}
int find_sum(int n, int m)
{
	int i, j, sum=0;
	for(i=1;i<n;i++)
		for (j = i + 1; j < n; j++) {
			if ((i*i + j*j + m) % (i*j) == 0)
				sum++;
		}
	return sum;
}

 //注意 !(n==0 && m==0)与n!=0&&m!=0不一样 ,这个点导致在oj上怎么都过不了 
 //疑惑????按题目意思应该是n!=0&&m!=0时程序退出 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值