Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S
3*W units if it walks a distance of S kilometers.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x
[i]<=x
[i+1] for all i(1<=i<N). The i-th line contains two real number : X
i,W
i, representing the location and the weight of the i-th spirit. ( |x
i|<=10
6, 0<w
i<15 )
Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
Sample Input
1 4 0.6 5 3.9 10 5.1 7 8.4 10
Sample Output
Case #1: 832
由于这些点是从小到大给出的,所以就不用排序了(其实这也是一个暗示,排好序的点+最值,很容易就想到三分)
#include<stdio.h>
#include<math.h>
#include<algorithm>
#define M 50007
using namespace std;
double x[M],w[M];
int n;
double calc(double a)
{
double ans=0;
for(int i=0;i<n;i++)
{
double dis=a-x[i];
if(dis<0)dis=-dis;
ans+=dis*dis*dis*w[i];
}
return ans;
}
int main()
{
int t,cas=1;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%lf%lf",&x[i],&w[i]);
double l=x[0],r=x[n-1],mid,midmid,mid_area,midmid_area;
while(r-l>1e-9)
{
mid=(l+r)/2;
midmid=(mid+r)/2;
mid_area=calc(mid);
midmid_area=calc(midmid);
if(mid_area<midmid_area)r=midmid;
else l=mid;
}
double ans1=calc(l);
double ans2=calc(r);
ans1=ans1<ans2?ans1:ans2;
printf("Case #%d: %.lf\n",cas++,ans1);
}
return 0;
}