1035 Lunch Rush (水题)

Lunch Rush

Time Limit: 2000/1000 MS (Java/Others)  Memory Limit: 128000/64000 KB (Java/Others)
Problem Description

Having written another programming contest, three Rabbits decided to grab some lunch. The coach gave the team exactly k time units for the lunch break.

The Rabbits have a list of n restaurants to lunch in: the i-th restaurant is characterized by two integers fi and ti. Value ti shows the time the Rabbits need to lunch in the i-th restaurant. If time ti exceeds the time k that the coach has given for the lunch break, then the Rabbits' joy from lunching in this restaurant will equal fi - (ti - k). Otherwise, the Rabbits get exactly fi units of joy.

Your task is to find the value of the maximum joy the Rabbits can get from the lunch, depending on the restaurant. The Rabbits must choose exactly one restaurant to lunch in. Note that the joy value isn't necessarily a positive value.

Input

There are multiple cases.

For each case, the first line contains two space-separated integers — n (1 ≤ n ≤ 104) and k (1 ≤ k ≤ 100) — the number of restaurants in the Rabbits' list and the time the coach has given them to lunch, correspondingly. Each of the next n lines contains two space-separated integers — fi(1 ≤ fi ≤ 104) and ti (1 ≤ ti ≤ 104) — the characteristics of the i-th restaurant.

Output

In a single line print a single integer — the maximum joy value that the Rabbits will get from the lunch.

Sample Input
2 5
3 3
4 5
4 6
5 8
3 6
2 3
2 2
1 5
1 7
Sample Output
4
3
-1
Source
Codeforces
题解: 此题就是判断一个最大值的问题,不需要记录全部值,只需要记录一个最大值即可
AC代码:
#include<iostream>
#include<algorithm>
using namespace std;

int main(){
    int n;
    long long int k,f,t,temp,mymax;
        while(cin>>n>>k){
            mymax=-111111111111111;
            while(n--){
                cin>>f>>t;
                if(t<=k){
                    temp=f;
                }
                else{
                    temp=f-(t-k);
                }
                mymax=max(temp,mymax);
            }
            cout<<mymax<<endl;
        }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值