HDU 1098 Ignatius's puzzle(数学归纳题or费马小定理)

                                                  Ignatius's puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8427    Accepted Submission(s): 5843

Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
 
Output
The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
 
Sample Input
  
  
11 100 9999
 
Sample Output
  
  
22 no 43
题解:

题目大意:方程f(x)=5*x^13+13*x^5+k*a*x;输入任意一个数k,是否存在一个数a,对任意x都能使得f(x)能被65整出。

现假设存在这个数a ,因为对于任意x方程都成立

所以,当x=1时f(x)=18+ka

又因为f(x)能被65整出,故设n为整数

可得,f(x)=n*65;

即:18+ka=n*65;

因为n为整数,若要方程成立

则问题转化为,

对于给定范围的a只需要验证,

是否存在一个a使得(18+k*a)%65==0

所以容易解得

注意,这里a只需到65即可

因为,当a==66时

也就相当于已经找了一个周期了,所以再找下去也找不到适当的a了

如果你非要证明的话,可以利用了取模过程与数的运算的次序上可交换原理简单证明一下

本身看看就知道,这里就不证了。。


AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
using namespace std;
#define MA 10010
int main()
{
 int n,i,k;
 while(~scanf("%d",&k))
 {
     for(i=1;i<=65;i++)
     {
         if((18+i*k)%65==0)
           {
              printf("%d\n",i);
              break;
           }
     }
     if(i>=66)
        printf("no\n");
 }

    return 0;
}


第二AC: 费马小定理
#include <cstdio>
int main()
{
	int k,flag;
	while (scanf("%d",&k)!=EOF)
	{
		flag=0;
		for (int i=1;i<=65;i++)
		{
                     if (i*k%13==8&&i*k%5==2)
                   { 
                        flag=i;
		        break;
                    }
		}
		 if (flag)
		{
			printf("%d\n",flag);
		}
		  else
		 {
			printf("no\n");
		 }
	}
}

这一题是一个好题,涉及到费马小定理!

什么是费马小定理呢?

费马小定理(Fermat Theory)是数论中的一个重要定理,其内容为: 假如p是质数,且Gcd(a,p)=1,那么 a(p-1) ≡1(mod p)。即:假如a是整数,p是质数,且a,p互质(即两者只有一个公约数1),那么a的(p-1)次方除以p的余数恒等于1。该定理是1636年皮埃尔·德·费马发现的。


所以我们要做的就是把这一题与费马小定理联系起来!


f(x)=5*x^13+13*x^5+k*a*x转化成f(x)=(5*x^12+13*x^4+k*a)*x


1.当x=65的倍数时就行了;

2.当x=5的倍数时则需要(5*x^12+k*a)是13的倍数,由费马小定理可知,因为x是5的倍数所以(x^(13-1)%13==1),所以(5*x^12%13==5),所以只需要做到k*a%13==8即可!

3.同理可得当x=13的倍数时,只需要做到(13*x^4+k*a)是5的倍数由费马小定理可知,因为x是5的倍数所以(x^(5-1)%5==1),所以(13*x^(5-1)%5==3),所以只需要做到k*a%5==2即可

4.当x不是上面的特殊数时,则需要f(x)=(5*x^12+13*x^4+k*a)*x被65整除,也就是需要同时满足上面那两个条件!



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值