HDU 1266 Reverse Number(模拟or数字字符串)

Reverse Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7836    Accepted Submission(s): 3372


Problem Description
Welcome to 2006'4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one... Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.
 

Input
Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.
 

Output
For each test case, you should output its reverse number, one case per line.
 

Sample Input
  
  
3 12 -12 1200
 

Sample Output
  
  
21 -21 2100
 

Author
lcy
 

Source



题解:不断的将数取模取最低位乘10加模。。。。不断循环,直到第一个数为止,尾数遇0则记录个数。。。

AC代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;

int main(){
	int n;
	LL m;
	cin>>n;
	while(n--){
		LL flag=0,t=0;
		int count=0;
		scanf("%lld",&m);
		if(m<0){
			m=-1*m;
			flag=1;
		}
		while(m>0){
			t=t*10+m%10;
			m=m/10;
			if(!t){
				count++; //计算0的个数 
		}		
	}
	if(flag==1){
				cout<<"-";
			}
			cout<<t;
			while(count--)
			{
			 printf("0"); 
		  }
		printf("\n");
		 
  }
  return 0;
}

字符串反向输出:我又没想到。。。。
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;

int main(){
	int t;
	char s[117];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",&s);
		int k=0;
	    int len = strlen(s);
		if(s[0]=='-')
		printf("-");
		int flag=0;
		for(int i=len-1;i>=0;i--)
		{
			if(s[i]=='0'&&flag==0)
			k++;
			else if(s[i]=='-')
			continue;
			else
			{
				flag=1;
				printf("%c",s[i]);
				
			}
		}
		for(int i=0;i<k;i++)
		  printf("0");
		  printf("\n");
	}

  return 0;
}


 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值