HDU 2035 人见人爱A^B(快速幂取模 )

人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34030    Accepted Submission(s): 23080


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input
  
  
2 3 12 6 6789 10000 0 0

Sample Output
  
  
8 984 1

Author
lcy
 
题解:快速幂取模 
AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
/*
int pow_mod(int a,int p)    //快速幂取模 
{
    if(p==0) return 1;
    int ans=pow_mod(a,p/2);
    ans=ans*ans%1000;
    if(p%2==1) ans=ans*a%1000;
    return ans;
}
*/
int pow_mod(LL a,LL b,int c){    //快速幂取模 
	LL ans=1;
	a=a%c;
	while(b>0){
		if(b&1){         //b&1相当于b%2==1
			ans=(ans*a)%c;
		}
		b=b>>1;  
        a=(a*a)%c;
	}
	return ans;
}
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        if(a==0&&b==0) break;
        printf("%d\n",pow_mod(a,b,1000));
    }
}

模拟:
#include<cstdio>
using namespace std;
int main()
{
    int a,b;
    while(scanf("%d%d",&a,&b)!=EOF)   
    {
        if(a==0&&b==0) break;
        int ans=1;
        for(int i=0;i<b;i++)   //模拟 
            ans=ans*a%1000;
        printf("%d\n",ans);
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值